Black screen applying Mosiac SLI Ubuntu 22.04 2xA6000

Hello I am trying to apply mosaic across 4 Q900A Samsung TVs, however, I am facing many issues that I cannot resolve.

Here is the X11/xorg.conf file:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 510.47.03

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Samsung Q900A”
HorizSync 15.0 - 255.0
VertRefresh 24.0 - 120.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA RTX A6000”
BusID “PCI:129:0:0”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “MetaModes” “GPU-0.DFP-0: 1920x1080 +0+0, GPU-0.DFP-1: 1920x1080 +1920+0, GPU-1.DFP-0: 1920x1080 +0+1080, GPU-1.DFP-1: 1920x1080 +1920+1080”
Option “SLI” “MOSAIC”
Option “MultiGPU” “Off”
Option “nvidiaXineramaInfo” “FALSE”
SubSection “Display”
Depth 24

Section “Extensions”
Option “Composite” “Disable”

As soon as I enable just mosaic and go for a restart with the 4 screens plugged in there is an issue where the server wont boot at all. I have tried countless combinations, tried suggestions such as turning off IOMMU. I also have an issue with linux where I cannot apply 8k resolution to one screen with just one plugged in. This feature works in windows but not linux.

To make the machine into a bootable state again I have to delete the /etc/X11/xorg.conf file, otherwise it will not boot at all. I am not sure if there are some logs I can access via going into recovery mode, if there are please can someone point me in the right direction for this.

Hi @oliver.jackson, welcome back!

Are you trying to run 4 time 8k resolution through one RTX A6000? That is sadly not possible, the max configuration is 2x8k at 60Hz.

But a single 8k monitor should most definitely work. One of the first suggestions, as you might expect, is to update to the latest driver version. Definitely does not hurt to try.

And to get a bit more details, could you check out this post on the Linux forums and provide the requested information listed there?