Black sreen with 2xT1000 on xubuntu 20.04 and CUDA 12.1

Good afternoon!
Another one classic problem with black screen on loading system Xubuntu 20.04. It is clean install.
We use:
motherboard: Asus Sage W299 10G
CPU: Intel(R) Core™ i9-10900X CPU @ 3.70GHz
GPU: 2xNvidia T1000 (in 1 and 3 slots)
Drivers: CUDA 12.1 and 530.30.02
After installation see only black screen. In Xorg.log
[ 14.130] () NVIDIA(G0): Stereo disabled by request
[ 14.130] (
) NVIDIA(G0): NVIDIA SLI Mosaic mode selected.
[ 14.130] (WW) NVIDIA(G0): Invalid Multi-GPU option: ‘true’; using single GPU rendering.
[ 14.130] (WW) NVIDIA(G0): Base Mosaic is available only on screen 0. Disabling Base
[ 14.130] (WW) NVIDIA(G0): Mosaic.
[ 14.130] (EE) NVIDIA(G0): Only one X screen is supported when Base Mosaic is enabled.
[ 14.130] (EE) NVIDIA(G0): Disabling this screen.
[ 14.130] (EE) NVIDIA(G0): Failing initialization of X screen
[ 14.130] (II) UnloadModule: “nvidia”
[ 14.130] (II) UnloadSubModule: “wfb”
[ 14.130] (II) UnloadSubModule: “fb”
[ 14.130] (EE) Screen(s) found, but none have a usable configuration.
[ 14.130] (EE)
Fatal server error:
[ 14.130] (EE) no screens found(EE)

[ 14.130] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 14.130] (EE)
[ 14.131] (EE) Server terminated with error (1). Closing log file.

I saved xorg.conf in X11 as previous for two videocards in motherboard. But it is doesn’t work.
It is very common problem with it I often come across.
I attach needed log files: dmesg, X.log, syslog, lightdm.log, kern.log. And collect info by nvidia-bug-report.log.gz

Please, help me with it problem.
bugreport.tar (59.3 MB)

First, please make sure

sudo cat /sys/module/nvidia_drm/parameters/modeset

returns “N”
Then please delete your /etc/X11/xorg.conf
and create a new /etc/X11/xorg.conf only containing

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:104:0:0"
    Option         "SLI" "Mosaic"

then reboot. In case it still doesn’t work, please create a new nvidia bug-report.log.

Good afternoon
Yes, checked it.

cat /sys/module/nvidia_drm/parameters/modeset

return N
When I delete xorg.xonf file, system load, but only 1 card work. I’ll try your advice. But as I read, option sli mosaic need to write in section screen. Didn’t try it previously.

They may be specified either in the Screen or Device sections of the X config file.

1 Like

Good afternoon
Could you help me? Same problem. And same system, but i need to change videocards. Now it is P2200 in 1 and 5 pcie slots.
If I don’t create xorg.conf system load. If i change mosaic and save xorg.conf on next boot black screen( If I try to enable second videocard on next boot blackscreen too(

cat /sys/module/nvidia_drm/parameters/modeset

return N
create a new /etc/X11/xorg.conf only containing

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:104:0:0"
    Option         "SLI" "Mosaic"

but error in xorg0.log because it is need basemosaic option.

By the way, if i run it is freeze and i couldn’t send you this info. nvidia-smi same problem, freeze.

arch.tar (10.1 MB)

Logs in attachment

In dmesg
[ 11.146586] nvidia-modeset: ERROR: GPU:1: Failed to query display engine channel state: 0x0000927c:0:0:0x00000057
[ 11.146601] nvidia-modeset: ERROR: GPU:1: Failed to query display engine channel state: 0x0000927c:1:0:0x00000057
[ 11.146610] nvidia-modeset: ERROR: GPU:1: Failed to query display engine channel state: 0x0000927c:2:0:0x00000057
[ 11.146618] nvidia-modeset: ERROR: GPU:1: Failed to query display engine channel state: 0x0000927c:3:0:0x00000057
[ 11.146651] BUG: unable to handle page fault for address: ffffbad3c13f1048
[ 11.146655] #PF: supervisor write access in kernel mode
[ 11.146658] #PF: error_code(0x0002) - not-present page

This rather looks like the second P2200 is either broken or incorrectly seated. Please check if it works alone in the slot of the other one.

Thank you for your quick reply! I’ll check it now and will write result

Checked. Two cards are work. I try to use firstly one card that we think was broken in slot 1. It is good.
Next i insert two cards in slots 1 & 5 as prev it was problem so black screen at loading.
Next as eject all pcie cards that it is not videocards. same problem.
Next I changed slot 5 to 2. So videocards in 1 & 2 slots. Same black screen and error message.
Found next when i delete xorg.conf and system start (only one card work). I open terminal, open nvidia-settings and it layout see what 2 cards present, but displays from 2nd card are disabled. Ok I click on advanced, then as previously set BasaMosaic see what can enable display from 2nd card to screen0. apply but nothing happen. but! It teminal see logs from nvidia-setting program Package xorg-server was not found in the pkg-config search-path … this package of course installed. And if i save config xorg.conf and reboot black screen( Try to change GPU-name to GPU-0, GPU-1 as prev. but no result(
maybe same advices? I can check it and show logs. Hope you help me. Motherboard Asus Sage W299 10G
and linux kernel 5.15.67-lowlevel.

Ok, please check if setting kernel parameter
makes it work.

Good afternoon!
Hope what it help with it, but no result( I add in grub loader when check kernel, iommu=off but black screen. In Xorg0.log last lines:

[ 10.187] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 10.188] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 10.188] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 10.198] () OutputClass “nvidia” ModulePath extended to “/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules”
[ 10.198] (
) OutputClass “nvidia” ModulePath extended to “/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules”
[ 10.205] (–) PCI: (104@0:0:0) 10de:1c31:1028:131b rev 161, Mem @ 0xd7000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000b000/128, BIOS @ 0x???/524288
[ 10.205] (–) PCI:*(105@0:0:0) 10de:1c31:1028:131b rev 161, Mem @ 0xd5000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x0000a000/128, BIOS @ 0x???/131072
[ 10.206] (II) “glx” will be loaded. This was enabled by default and also specified in the config file.
[ 10.206] (II) LoadModule: “dbe”
[ 10.206] (II) Module “dbe” already built-in
[ 10.206] (II) LoadModule: “extmod”
[ 10.206] (II) Module “extmod” already built-in
[ 10.206] (II) LoadModule: “glx”
[ 10.207] (II) Loading /usr/lib/xorg/modules/extensions/
[ 10.216] (II) Module glx: vendor=“X.Org Foundation”
[ 10.216] compiled for 1.20.13, module version = 1.0.0
[ 10.216] ABI class: X.Org Server Extension, version 10.0
[ 10.216] (II) LoadModule: “nvidia”
[ 10.216] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/
[ 10.223] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 10.223] compiled for, module version = 1.0.0
[ 10.223] Module class: X.Org Video Driver
[ 10.224] (II) NVIDIA dlloader X Driver 530.30.02 Wed Feb 22 03:49:34 UTC 2023
[ 10.224] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 10.229] (II) Loading sub module “fb”
[ 10.229] (II) LoadModule: “fb”
[ 10.229] (II) Loading /usr/lib/xorg/modules/
[ 10.230] (II) Module fb: vendor=“X.Org Foundation”
[ 10.230] compiled for 1.20.13, module version = 1.0.0
[ 10.230] ABI class: X.Org ANSI C Emulation, version 0.4
[ 10.230] (II) Loading sub module “wfb”
[ 10.230] (II) LoadModule: “wfb”
[ 10.230] (II) Loading /usr/lib/xorg/modules/
[ 10.231] (II) Module wfb: vendor=“X.Org Foundation”
[ 10.231] compiled for 1.20.13, module version = 1.0.0
[ 10.231] ABI class: X.Org ANSI C Emulation, version 0.4
[ 10.858] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 10.858] (==) NVIDIA(0): RGB weight 888
[ 10.858] (==) NVIDIA(0): Default visual is TrueColor
[ 10.858] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 10.858] (II) Applying OutputClass “nvidia” options to /dev/dri/card1
[ 10.858] (
) NVIDIA(0): Option “Stereo” “0”
[ 10.858] () NVIDIA(0): Option “nvidiaXineramaInfoOrder” “DFP-4”
[ 10.858] (
) NVIDIA(0): Option “SLI” “off”
[ 10.858] () NVIDIA(0): Option “MultiGPU” “Off”
[ 10.858] (
) NVIDIA(0): Option “BaseMosaic” “on”
[ 10.858] () NVIDIA(0): Option “AllowEmptyInitialConfiguration”
[ 10.858] (
) NVIDIA(0): Stereo disabled by request
[ 10.858] () NVIDIA(0): NVIDIA SLI disabled.
[ 10.858] (
) NVIDIA(0): NVIDIA Multi-GPU disabled.
[ 10.858] () NVIDIA(0): Option “MetaModes” “GPU-0.DP-4: nvidia-auto-select +0+0, GPU-0.DP-0: nvidia-auto-select +3840+0, GPU-1.DP-4: nvidia-auto-select +7680+0”
[ 10.858] (
) NVIDIA(0): Enabling 2D acceleration
[ 10.858] (II) Loading sub module “glxserver_nvidia”
[ 10.858] (II) LoadModule: “glxserver_nvidia”
[ 10.858] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/
[ 10.932] (II) Module glxserver_nvidia: vendor=“NVIDIA Corporation”
[ 10.933] compiled for, module version = 1.0.0
[ 10.933] Module class: X.Org Server Extension
[ 10.933] (II) NVIDIA GLX Module 530.30.02 Wed Feb 22 03:51:52 UTC 2023
[ 10.934] (II) NVIDIA: The X server supports PRIME Render Offload.
[ 11.719] (II) NVIDIA(GPU-0): NVIDIA Base Mosaic enabled.

Good afternoon!
I got again server with [2xT1000 on xubuntu 20.04 and CUDA 12.1] but with other motherboard. I install clean xubuntu 20.04 lts. And i forgot to say what i install not only nvidia-driver, I install cuda with nvidia driver. It is install latest cuda 12.1 and nvidia driver 530.30.02. Same problem. If I set BaseMosaic true and save config, it is black screen after reboot. If i save config and set basemosaic false, system load but i couldn’t use two cards in one layout(
Hope You will help me. Our maybe you advice me how correctly downgrade cuda & driver version when it is installed. For example I need to install driver 515 remember it is work correct.

Guys, good afternoon!
Still have this problem. I didn’t understand why 2xT1000 couldn’t work in base mosaic mode. linux xubuntu 20.04.6 with cuda 11.7 and driver 515.43.04 . Please help. Can show all need information.

upd: And one more information. When I remove xorg.conf (as previously) system start. And i check this case connect display to 2nd card and open nvidia-setting and saw what display show and hide in loop in 2-3 second. If i disconnect it from card and plug again.

upd2: and in Xorg0.conf saw
[ 301.544] randr: failed to create shared pixmap
[ 301.544] (EE) NVIDIA(G0): Failed to configure Reverse PRIME on output DP-1-5.