multiGPU mosiac with 2 T1000 cards on ubuntu not working

Hi i am folowing below document
https://nvidia.custhelp.com/app/answers/detail/a_id/3580/~/how-to-configure-mosaic-on-linux

trying to create mosaic using two T1000 cards i apply changes through nvidia control panel by creating mosaic of 4x2 but when we retart the system it shows all independt display.

i tried from display configuration as well and created in 4x2 it arrange in 4x2 but display in not streachable 4x2
please help to resolve the issue
how we create single 4x2 mosaic using 2 GPUs or more.

please anyone first confirm is 4 T1000 cards mosaic of 4x4 is possible with 1920x1080@60 fps display?
as i am able to create mosaic with single T1000 card
i have problem while use multple cards

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.
Also, please post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

I’m facing a similar setting as the OP, so I’m interested in this thread as well.

Regarding /sys/module/nvidia_drm/parameters/modeset, what is the expected value? (I assume it should be Y, but just double-checking. It is currently N in my system).

Thanks

For Mosaic to work, the correct setting results in ‘N’.

I’m just trying now, but for some reason I cannot get it to work. Some details about my setting:

Ubuntu 20.04.4 LTS
2 x NVIDIA T1000 (but right now both monitors connected to the same card)
$ sudo cat /sys/module/nvidia_drm/parameters/modeset
N

Screen section of my /etc/X11/xorg.conf file:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-6"
    Option         "metamodes" "GPU-35403735-95d2-5b51-2a2b-2d8b9e6a62d1.DP-6: nvidia-auto-select +0+0, GPU-35403735-95d2-5b51-2a2b-2d8b9e6a62d1.DP-2: nvidia-auto-select +3840+0"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

It boots OK, and both monitors are correctly positioned, I can move windows no problem from one monitor to the other, etc. but trying to go into FullScreen (F11) in Firefox (for example), just expands its Window in one of the monitor, not both.

Any suggestions as to what might me missing in my setting?

Thanks,

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Here it is.
nvidia-bug-report.log.gz (555.3 KB)

Please delete /usr/share/X11/xorg.conf.d/10-nvidia.conf
and add to your xorg.conf

Section "Files"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
EndSection

Many thanks, but I’m afraid I still see (after rebooting) the same behaviour. Just in case, I attach the new nvidia-bug-report.log.gz file.

nvidia-bug-report.log.gz (550.9 KB)

Only now taken a look at your whole config, BaseMosaic was working fine before. Both monitors are connected to the same gpu, in general, you only have two monitors, why are you using Mosaic at all?
Moreover, the MetaMode doesn’t match your setup, you’re using DFP-7 (HDMI) and DFP-2(DP) (GPU0.DP-7 and GPU0.DP-2) but settings are for DFP-6.
Please remove the Metamode and Xineramainfoorder settings. After reboot, please post the output of
xrandr --listmonitors

Hello,

just deleted the lines you were telling me:

[angelv@muro2 ~]$ tail -n 20 /etc/X11/xorg.conf

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Files"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
EndSection

and after reboot this is what xrandr gives me:

[angelv@muro2 ~]$ sudo xrandr --listmonitors
Monitors: 2
 0: +*GPU-0.DP-2 3840/600x2160/340+0+0  GPU-0.DP-2
 1: +GPU-0.DP-7 3840/600x2160/340+3840+0  GPU-0.DP-7

This is the first time I try to use Mosaic. Right now I only have two monitors connected to one GPU card, but in the near future I will have probably six monitors, perhaps three monitors in each card.

The only real reason why I’m trying to set Mosaic now, is just because I need that FullScreen expands to both monitors and not just one (and so far I couldn’t find any other way of doing it…).

Cheers

Ok, I completely misunderstood your issue, I’ve based anything on the OP.
To merge monitors into one, independently of Mosaic, xrandr can be used:
xrandr --setmonitor LargeOne auto GPU0.DP-7,GPU0.DP-2
might work. Please consult the xrandr manual if not.
This requires using a moderm WM with support for xrandr monitor objects. (current gnome or kde should work).

Thanks. I did try, but to no avail. I don’t seem to be able to get it. I will try something else instead and will come to this later on if the other option brings me to a dead end.