Bluetooth (A2DP) Auto Re-Connection issue with android and Jetson nano using Bluez 5.63

I have configured Bluetooth a2dp profile and automated the connection Process in linux using bluez and the bash script, making sure the device is already paired

agent NoInputNoOutput

It works and I am able to connect from Android Phone by pressing the Connect button in Bluetooth Setting, But the problem is when the Jetson Nano reboots then the ‘bluetoothctl’ script does not work to create a connection directly from jetson, and still requires me to press the button from phone.
When I tried the Blueman-manager to connect directly from Jetson Nano, it gives the following error message:
Connection Failed: Did not receive a reply: Possible causes may be:The remote application did not send a reply, or the message bus security policy blocked the reply

So how to enable the jetson to connect directly to paired device over A2DP profile, without pressing the connect button from Android phone.

I am using
Nvidia Jetson Nano
SDK Jetpack 4.6
BlueZ Version 5.63
Android Version 11

The devices are already paired, I tried to make the Bluetooth A2DP Connection directly from Jetson Nano to Android Using Bluez.
I’m expecting that when I try to connect directly from jetson to paired android device it should get connected. But It requires me to press the connect button from android bluetooth setting


I have moved this topic to the Jetson Nano category for visibility.

We don’t have much experience on Bluetooth, you may check below threads to see if can gain some ideas:
Airpods Pro Bluetooth Connection - Jetson & Embedded Systems / Jetson Xavier NX - NVIDIA Developer Forums
Bluetooth connects and disconnects on Nano 2GB - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.