Breakpoints not hit

Using Nsight 2.2 for VS2008, I set breakpoints in my kernel code, but they are not always hit.

I can usually get them to break by deleting and re-inserting the breakpoint while the kernel is running.

I did not have this problem with previous versions of Nsight. Please fix this.

Can you provide more info on the configuration? GPU(s), CUDA version, driver version, local or remote debugging?
Are you able to reproduce this with any of the samples?

If possible, could you try Nsight 3.0 RC1?
Thank you

Windows 7 HP SP1
CUDA v5.0
Driver v9.18.13.694 on GT525M
local debugging with Optimus

Any luck with RC1? What is the model of your laptop?

I have not tried RC1 yet. Lappy is Dell XPS 15z. 525M w 2GB

OK, I loaded and ran my project with RC1 and get the same result.

Breakpoint set before startup does not break. If I remove it and re-add it, it breaks right away.

Unfortunately I haven’t been able to reproduce the issue with a similar chip. Does this issue occur with any of the samples?

I was not able to reproduce this with either of a couple of samples.

It may be due to integration of OpenGL/CUDA interoperability into my project rather than a new version of Insight. My kernel is now writing to a PBO.

However, the Mandelbrot sample does not have this problem.

Any chance we can take a look at your code to see why this issue is occurring?

When I get some time to pare down my code…