Microsoft Surface - Cannot hit breakpoints

Hi,

I have a surface book which I have been using for cuda development on the go. It had been working fine for several years, but in the last few months breakpoints in nsight for visual studio have stopped working.

Device query shows everything looks normal:

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GPU"
  CUDA Driver Version / Runtime Version          10.0 / 9.0
  CUDA Capability Major/Minor version number:    5.0
  Total amount of global memory:                 1024 MBytes (1073741824 bytes)
  ( 3) Multiprocessors, (128) CUDA Cores/MP:     384 CUDA Cores
  GPU Max Clock rate:                            993 MHz (0.99 GHz)
  Memory Clock rate:                             2505 Mhz
  Memory Bus Width:                              64-bit
  L2 Cache Size:                                 1048576 bytes
  Maximum Texture Dimension Size (x,y,z)         1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
  Maximum Layered 1D Texture Size, (num) layers  1D=(16384), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers  2D=(16384, 16384), 2048 layers
  Total amount of constant memory:               65536 bytes
  Total amount of shared memory per block:       49152 bytes
  Total number of registers available per block: 65536
  Warp size:                                     32
  Maximum number of threads per multiprocessor:  2048
  Maximum number of threads per block:           1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size    (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch:                          2147483647 bytes
  Texture alignment:                             512 bytes
  Concurrent copy and kernel execution:          Yes with 4 copy engine(s)
  Run time limit on kernels:                     No
  Integrated GPU sharing Host Memory:            No
  Support host page-locked memory mapping:       Yes
  Alignment requirement for Surfaces:            Yes
  Device has ECC support:                        Disabled
  CUDA Device Driver Mode (TCC or WDDM):         WDDM (Windows Display Driver Model)
  Device supports Unified Addressing (UVA):      Yes
  Device PCI Domain ID / Bus ID / location ID:   0 / 1 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 10.0, CUDA Runtime Version = 9.0, NumDevs = 1, Device0 = GeForce GPU
Result = PASS

I am using the integrated Intel graphic chipset as the driver of the display, so the nvidia gpu is dedicated for cuda. Nsight does not give any errors when I debug, it just does not hit the breakpoints. I am running cuda 10.0 and latest nsight (6.0). My nvidia GeForce GPU display driver is version 25.21.14.1735 (11/12/2018).

Should I try to install older version of the nvidia drivers to see if this is the problem or old versions of nsight? Any pointers would be appreciated.

Hello,

According to the information in the link below, the recommended drivers for Nsight 6.0 are 411.63.

https://developer.nvidia.com/gameworksdownload#?search=nsight-visual-studio-edition

Let me know how it goes for you.

Best,
Tom

This makes it look to me like you are running CUDA 9.0:

Device 0: "GeForce GPU"
  CUDA Driver Version / Runtime Version          10.0 / 9.0

And while I’m not saying its the source of your problems, I would ordinarily not like to see the GPU descriptor listed as “GeForce GPU”.

maybe your environment needs to be tidied up

While this is strange, it appears to be normal for a Microsoft Surface based on what I can find on the internet. Maybe there is an agreement between NVIDIA and Microsoft not to reveal the exact GPU type.

Thanks, I am running cuda 8,9,10 for backward compatibility purposes, accidentally ran the output above from 9 not 10.

The driver version is tricky as the surface only accepts the OEM driver from Microsoft, and according to Windows update this is the latest version. I have read some people manage to install the Nvidia reference drivers by changing the inf files but I didn’t want to do this.

Doing an uninstall of existing Nvidia driver and running DDU got my machine clean, and then manually installing the driver from the Nvidia 411.63 temp folder solved this (for some reason the official installer gets stuck on the software license agreement screen…).