Buffer ID bug?

Hi,
I have weird error when I am using buffer id.
I create optix buffer and set its id into program by

program["bufferID"]->setInt(buffer->getId())

It works fine, but when I need to change buffer size, I remove it and create new one.
And now I got this error:

Unknown error (Details: Function "_rtContextLaunch2D" caught exception: Assertion failed: "buffer->getOffset() != Buffer::INVALID_OFFSET", [5767745])

It can be fixed by calling remove varible before set:

program->removeVariable(rtContext["bufferID"]);
program["bufferID"]->setInt(buffer->getId())

After that it works fine again.
Have somebody same problem? It can be fixed by other way?

We fixed some surrounding bugs in OptiX 3.6.3. Does this one still fail?

Yes, also with Optix 3.6.3.

I tried it also in newest 3.7.0 beta 3 version and still same error. Any news about fix?

>>It works fine, but when I need to change buffer size, I remove it and create new one.<<

For clarification, why do you remove the buffer and create a new one instead of changing the size of the existing buffer?
In the latter case the ID should remain the same and the buffer ID variable wouldn’t need to be touched.

Could you please provide a complete reproducer in failing state?
Please read the post about the OptiX API Capture in this thread: https://devtalk.nvidia.com/default/topic/803116/optix/error-with-rtpmodelupdate/
Include the following system information to be able to match the setup:
OS version, OS bitness, installed GPU(s), display driver version, OptiX version, CUDA version.

Hi Jan,
I can’t get this to reproduce based just on the description. If you make an OAC trace we can take a look.