[BUG] nVidia drivers 370.23 Vulkan

Version 370.23 has some problem on the Vulkan backend causing lockups of the system while running Vulkan apps. I reported this on Dota2, but another user was able to pin point the problem to the driver and something related with vkWaitForFences.

Getting a similar issue trying to run the Talos Principle with Vulkan on 370.23.

After some testing here is a description of the problem and how to reproduce system lockup:

  • Have 370.23 driver installed
  • Open Vulkan game (I tested Dota2 and vkquake)
  • Move the game in windowed mode. It will cause a slight hiccup.
  • Closing from within game OR using mouse / alt-tab to switch to another application.
  • System stops responding

I press ctrl+alt+f1 and wait for 30 secs - 90 secs until tty1 appears. App process have 100% usage (sometimes xorg have 100% usage too) in one thread. Sometimes it stop eating usage the moment you get to tty1.

There’s a an error I only produced with vkquake when starting a new game. Strangely, if ran valgrind it runs fine (except when the prev steps are done), but I ran binary alone it throws vkWaitForFences error. Here’s vkquake log: http://pastebin.com/rNeCDLPG. Valgrind log: http://pastebin.com/hvQTPX3V.

Used binaries for vkquake 0.70.0 release from this repository: https://github.com/Novum/vkQuake

Of course, I tried the current long lived branch (367.44) and everything works flawlessly.
nvidia-bug-report.log.gz (101 KB)

This appears to be a reproduction of my issue here:

https://devtalk.nvidia.com/default/topic/953498/linux/367-35-talos-principle-vulkan-takes-a-long-time-to-load-and-crashes-a-few-seconds-after-loading-a-l/

As reported on my update for 370.23 drivers.