Can drive xavier use nvpmodel?

Hi,

I try to open high performance mode in drive xavier with nvpmodel.But this tool cannot work.How can I fix it ?

And is there some tools like jetson_clocks.sh and tegrastats in TX2 ?

nvidia@tegra-ubuntu:~$ sudo nvpmodel -q                                                                                                                                                  
NVPM ERROR: failed to read /var/lib/nvpmodel/conf_file_path
NVPM ERROR: Failed to read config file path, try default
NVPM ERROR: Failed to find default config file from:
NVPM ERROR:     /odm/etc/nvpmodel.conf
NVPM ERROR:     /vendor/etc/nvpmodel.conf
NVPM ERROR:     /etc/nvpmodel.conf

Hi zwunzs98,

I quickly tested your command and it worked on my side, Xavier running JetPack 4.2.

nvidia@nvidia-desktop:~$ sudo nvpmodel -q
[sudo] password for nvidia: 
NV Power Mode: MODE_15W
2
nvidia@nvidia-desktop:~$

Have you tried to run jetson_clocks?

Regards,
Greivin F.

Hi greivin.fallas.

My machine is drive xavier,not jetson xavier.Drive xavier cannot install Jetpack.

Hi zwunzs98,

The nvpmodel only support in Jetson platform, it’s designed for different power efficient use cases, it can’t be used on DRIVE AGX platform.

Thanks

Hi kayccc,

Thank you,I got it.

And is there another way to change power mode ?