Jetson AGX Xavier: nvp modelservice failed

When i switch on AGX Xavier developer kit, i am facing the follwing error in the screen, after which i am not able see the login console.

[Failed]: Failed to start nvp modelservice

Kindly suggest the fix.

  1. Share which jetapck release you are using.

  2. Use ctrl + alt + F1~6 to see if you can switch to console.
    And use systemctl to check what happened to nvpmodel service and gdm3 service.

Thanks for your reply.

  1. I am using jetpack 4.6 rev2 which got populated automatically during sdkmanager installation.
  2. When i tried to switch to console, the screen is not stable. It is continuously blinking. But i managed to enter the credentials and got the screenshot of nvpmodel service and gdm3 service. Kindly find the attached image.

It looks like the installation from sdkmanager has something corrupted.

The log says your nvpmodel binary does not exist. Could you check the rootfs on your host machine and see if this exists in sdkmanager folder?


Could you please give some more insights. What file should i have to look in rootfs(where is rootfs in my host pc).

I have checked the following path as in the image below. I am able to locate nvpmodel. Is that the path you want me to look at. kindly let me know.

Yes, then please flash your board again. Maybe previous flash has something wrong.

Thanks! I have tried it couple of times, i didn’t succeed. Got stuck in the same page.


Can you check if this file really does not exist on your jetson xavier?

Hi @murugan,

nvpmodel helps define the clock modes, i.e how many cores to use and the frequency for CPU and GPU.
In your case it seems the there is some issue with the nvpmodel files,

  1. Change the Jetpack version and try the installation.
  2. Reinstalling the os onto the device.

Now the screen is flickering now. Not able to enter into the console (ctl+Alt_F1~6)

Could you use below method to interact with the board instead of using the monitor and keyboard on device?

thanks for your input hitesh. I have ubuntu 18.04 ,both in host and target. not sure about upgrading (whether the packages are available). Because when i used ubuntu 20.04, sdk manager was showing a message on unavailability of jetpack support. Hence i reverted back to 18.04. If you have used 20.04 let me know.

I meant, is it possible for you to use a different version of the Jetpack.
If I am not wrong you are using jetpack V4.6, could you some other version of the jetpack and check??

Sure Hitesh. I will try. But any how in future, i want in particular version(4.6) due to its triton inference support.
Thanks again.

I didn’t find it xavier(nvpmodel).

Ok, could you reply below questions?

  1. What did you do after each flash with sdkamanger? Did you configure your user account each time over the HDMI monitor? Is it always failed with nvpmodel? or something else would fail too?

  2. Could you copy and paste the boot log from this uart serial console and attach the full log?

Hello ,

I have been facing this issue on my NVME and the EMMC both and using the same Jetpack installed with sdkmanager_1.6.1-8175 which was updated to 1.7.xxxx .
The screen after installation of OS at AGX Xavier loads up and I setup lan and select country , then it resets and NEVER I see anything. What I see is the attached images:

If you are new to this issue, please go through all the comments I have shared and give your result.


  1. Each time my user account credentials was validated. It always failed with nvpmodel. No other models got failed.
  2. Before attaching the boot log from uart serial console, i jst removed the manually and reinstalled nvidia-l4t-3d core. The console(GUI) started appearing. Though nvpmodel error is still there, now i am able to see the login screen.
    Attached is the screenshot.

Hi Hitesh,

My console screen with GUI started coming. There was some broken packages. I have manually removed and re-installed it again. But still nvpmodel error is there. I will use some other jetpack or reflash it.
Thanks for your support. Attached is the screen shot.