Can not build ffmpeg with gpu acceleration on TX2

I run command like this:
./configure
–prefix="/opt/ffmpeg/build"
–pkg-config-flags="–static"
–extra-cflags="-I/opt/ffmpeg/build/include"
–extra-ldflags="-L/opt/ffmpeg/build/lib"
–bindir="/opt/ffmpeg/bin"
–enable-gpl
–enable-libass
–enable-libfdk-aac
–enable-libfreetype
–enable-libmp3lame
–enable-libopus
–enable-libtheora
–enable-libvorbis
–enable-libvpx
–enable-libx264
–enable-libx265
–enable-nonfree
–extra-cflags=-I…/nv_sdk
–extra-ldflags=-L…/nv_sdk
–extra-cflags="-I/usr/local/cuda/include/"
–extra-ldflags=-L/usr/local/cuda/lib64
–disable-shared
–enable-nvenc
–enable-cuda
–enable-cuvid
–enable-libnpp

but this output an error like :
ERROR: cuvid requested, but not all dependencies are satisfied: cuda

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file “ffbuild/config.log” produced by configure as this will help
solve the problem.

Someone know why?

The version of FFmpeg I compiled is 3.4.

Hi, it is not supported. Please refer to
https://devtalk.nvidia.com/default/topic/1002969/jetson-tx2/how-to-build-ffmpeg-with-harware-acceleration-on-tx2-/post/5124369/#5124369