Can not launch Triton Container of Voice Demo for Jetson/L4T on JetPack 4.6

When I ran the command

$ sudo docker run --runtime nvidia -it --rm --network host \
    nvcr.io/nvidia/jetson-voice:r32.4.2 \
    trtserver --model-control-mode=none --model-repository=models/repository/jasper-asr-streaming-vad/

as the instrument in NVIDIA NGC, I got an error as below:

docker: Error response from daemon: failed to create shim: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: Running hook #0:: error running hook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-cli --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --compat32 --graphics --utility --video --display --pid=7157 /var/lib/docker/overlay2/d05560c337782b99499c72d2a96db0521050bd6e835fabaeb54aa164acf87920/merged]
nvidia-container-cli: mount error: file creation failed: /var/lib/docker/overlay2/d05560c337782b99499c72d2a96db0521050bd6e835fabaeb54aa164acf87920/merged/usr/lib/aarch64-linux-gnu/tegra/libnvidia-fatbinaryloader.so.440.18: file exists: unknown.

Hi @monchatparle, are you running JetPack 4.4 Developer Preview (L4T R32.4.2)? This demo/container is only for that version of JetPack.

For more recent version of jetson-voice, please refer to this GitHub repo:

Hi Dusty,

Thanks for your reply.
I have tried jetson-voice in different JetPack. I found that I cound not run the demo below

$ examples/asr.py --model matchboxnet --wav data/audio/commands.wav

on JetPack 4.6, But I can run it on JetPack 4.5.

For some reason there is an issue with latest TensorRT and ASR classification models (like matchboxnet and vad_marblenet). However the normal ASR transcription (quartznet) still works fine on JetPack 4.6. It’s something I need to debug.

Thanks for your great job.