Can not play the Jetbot in Omniverse Isaac Sim Application

Now I can find the Jetbot in the menu: Issac Robotics in the application window.

But after I did Load Jetbot scene, then press the Play button, the keyboard map does not work for me (Jetbot doesnot move at all).

w: forward
s: reverse
a: left spin
d: right spin

Also I have seen the message:
[Error] [omni.isaac.dynamic_control.plugin] DcSetDofVelocityTarget: Invalid or expired dof handle

shown on the command shell window where I run:
./_build/linux-x86_64/release/isaac-sim.sh.

Could you please let me know how to fix the problem to run this Jetbot sample on the Omniverse-Isaac-Sim?

Thanks
Jimmy

Hi

Try to reload the Isaac Sample extension from the kit. Go to Window > Extension Manager and uncheck omni.isaac.samples. Then enable it and try again.

Thanks. I will give it a try

I am facing the same issue, did you solve it?

@oliverB, sorry I did not got chance to try since I am not working on the ISAAC anymore at least for now.

@oliverB @jqin2014m7df9
can you confirm that in your nucleus folder the version file says version-2020.2.2.1106.md
if you see version-2020.2.1026.md that means you have the assets from the 2020.2 release and not the newer 2020.2.2 hotfix release

The issue is an update to the joint names for jetbot between 2020.2 and 2020.2.2

1 Like

This solved the problem thank you, i initially added the assets from Method #2: Mount, but this had the old version. Using method 1, i got the updated assets.