Cannot boot after driver upgrade on Ubuntu 20.04

Hi all,

The whole problem started when I tried to connect to the GPU in order to get the correct version of cuda. Unfortunatly it didn’t work and I ended updating the driver as mentionned in the error code. Using Ubuntu 20.04 and Titan GPU I removed the current driver (460.xx, remove + sudo autoremove) and installed the recommanded one (470.xx). The installation went fine but when i reboot I am stuck on a blinking black screen with a cursor. I tried many things like removing installing another version, modified the kernel nomodeset (i have access to the terminal), enabling/disabling waylands, The commands nvidia setttings and nvidia-smi are not working. I can’t acess the bios and I don’t know if uefi could be the cause of this problem. Attached to this post is the bug report if someone can help. If more info are needed do not hesitate since i already spent many hours on that problem.

Best regards,

nvidia-bug-report.log.gz (188.8 KB)

You installed the runfile driver over the ubuntu packages, leading to a mismatch:

NVRM: API mismatch: the client has the version 470.86, but
NVRM: this kernel module has the version 470.82.00.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

Please run the runfile installer with --uninstall option, then purge and reinstall the repo driver.