Cannot establish smbus connection for battery


I am using Jetson AGX Orin 32GB Developer Kit at version 5.1.1

I have a battery with smbus connection. I want to establish SMBus connection from i2c. There is SDA, SCL, Negative and Positive. So I soldered a jack for negative and positive then two jumper for SDA anc SCL. Then I checked them with ammeter.

Battery can power the Orin but when I connected SDA (3rd pin) and SCL(5th pin). I can get no result for
i2cdetect -y -r 0…8

I tried to use

sudo su
sudo sh -c 'for i in 2 3 4 5 6 7 8 9; do echo 1 > /sys/kernel/debug/bpmp/debug/clk/i2c$i/mrq_rate_locked; done'
sudo sh -c 'for i in 2 3 4 5 6 7 8 9; do echo 100000 > /sys/kernel/debug/bpmp/debug/clk/i2c$i/rate; done'

(I also tried 10khz, 1khz)

Then tried i2cdetect again but still there is no result. Am I doing something wrong? Can I get SMBus connection for battery?

Please probe the i2c signal to confirm the device ack for the command.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.