Jetson orin not responding and not detected

Hi,

We bought a jetson orin for Robotics ussage. We followed the “getting started” and we were able to configure the orin. However, we ran into several problems, firstly I was unable to see the M.2. SSD, then I was unable to configure GPUs properly so my cuda based dockers can run on it. Then, I installed cuda from apt get, got a no space left warning and now the Orin does not load.
If I plug it, it shows the first screen with the NVIDIA logo and the “Warning: Test Key is used”, after this screen nothing is shown anymore (orin seems to still work since it activates the fan from time to time).
Hence, I decided to flash it again using the SDK Manager. However, it is not detected in my host machine.
I am using usb-c to usb-a cable connected to the usb-c frontal port of the orin. I follow the instruccions with the Orin powered off, pressing the middle button and then the left button. It seems to start but nothing is shown at all.
From my host computer I am unable to see the Orin, nethier from the sdkmanager neither from lsusb.
The usb keeps giving an errror
Nov 22 11:39:43 me00 kernel: [ 795.352146] usb usb2-port2: config error
Nov 22 11:39:47 me00 kernel: [ 799.427980] usb usb2-port2: Cannot enable. Maybe the USB cable is bad?

My host computer is an ubuntu 20.04, I have tried to change the cable (I am using the one provided by the same orin), changed also the port… but nothing seems to work.
Is there anything I can do to recover connection to the orin?

Thanks

Hi, bernat.gaston,

Are you using the devkit or custom board?

This is to enter Force Recovery Mode. You should see information by lsusb when the board is in Force Recovery Mode.
To Determine Whether the Developer Kit Is in Force Recovery Mode

After you see your device in Force Recovery Mode by lsusb, you could refer to the following link to flash board by SDK Manager with Manual Setup.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

Hi,

Thanks for the response. Apparently Orin is not responding to the procedures for the force recovery mode (middle button + reset or middle button + power on), but it responded to the procedure middle button + usb plug. Previously, I was doing the recovery procedures with the usb cable already plugged in. When I did the middle button + usb cable plug with the Orin in poweroff mode, it worked.