Orin won't boot


I’m attempting to get my Orin to boot however I don’t get any signs of life. Pressing the power button results in quite literally nothing happening (the fan doesn’t spin up, no light indicating it is powered on, no output to my monitor, etc.). I’ve tried multiple different USB-C power sources across both ports as well as the DC power jack using multiple sources. I also tried hooking into the debug port but my computer doesn’t even recognize it being plugged in. Force recovery mode was unsuccessful in doing anything as well.

Is there anything else I can try here or does it appear this unit needs to be sent in for repairs?

I think you can describe what is the debug port you are using to check here.

Also, what was your expectation to recovery mode? Recovery mode is not recovering anything. It is just a mode that you have to enter so that host PC can reflash it.

Thanks for the reply Wayne! I tried connecting via the micro-USB port shown as port 9 in the link below to my Linux box to see if I could get any data out of it, but nothing popped up:

Quite frankly I was just seeing if I could get something to happen by putting the box into recovery mode as a coworker mentioned giving that a shot.


After entering recovery mode, you need to use another x86 host PC (ubuntu20.04) + sdkmanager to flash your jetson.

I installed the SDK Manager, but it doesn’t detect the board which is definitely plugged in. I also tried using minicom to see if I could detect it and that was unsuccessful as well.

I’m still at this point leaning toward something on the board being dead as when I power on I (in recovery mode or not) I don’t see the white LED (item 0 on that Hardware layout I linked earlier) turn on and the fan doesn’t spin.


Just to confirm. Are you talking about even the LED is not on?

Yep, that’s correct! I’ve tried multiple different USB-C cables to power the device plus the DC power jack and I can’t for the life of me get that white LED to turn on.

Do you have other Orin AGX on your side to validate those dc power jack really can boot it up? Or to validate whether your method to power up the board is correct?

Yep, I don’t think that’s an issue. My team has two other Orin’s that are working fine. I grabbed the USB-C cable/blocks that we were using for those and tested with this unit and could not get that LED to turn on. I did the same with my DC power adapter and while those two Orin’s could be powered on, this unit I made the post about did not turn on. My coworkers who are actively developing with those units could not get this one to work either.

Please RMA this board. If no LED is on, sounds like hardware problem.

Thank you for the confirmation. I was informed by Customer Support that the Orin I have is past its 1-year warranty and they will not fix it, nor do they have any paid repair services. A bit disappointing to hear how short this period is, but in any case thank you for troubleshooting this issue with me.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.