AGX Orin won't power on

AGX Dev Kit is not powering on. I have tried several troubleshooting methods.

  1. Tried powering through USB-C. No Lights or Fan running
  2. Tried powering through DC Barrel Jack. Same result as USB-C
  3. Tried to get access to the serial monitor. The USB device isn’t listed when I plug it in.
  4. Tried running the SDK Manager, to see if I could re-flash but the board doesn’t get detected.

Please let me know if you need any additional information!

Are you using the right micro USB port?

Do you know how to put the device in force recovery mode?

Thanks for the reply!

I tried using the USB - C port, and the micro USB port, but it doesn’t appear under /dev/tty/ACM*

I have previously flashed the Jetson, and followed the steps here, but I don’t seem to be getting any power to the unit itself:

/dev/ttyACM0 will only come up after the power cable is connected.

How about this?

I got the debug console working after plugging it into the Micro USB, but nothing seems to appear. I might be doing something wrong. I used minicom -D /dev/ttyACM0 -8 -b 115200

I followed the following steps:

For powered on, holding the force recover button, holding the reset button and releasing both.

For powered off, holding the force recovery button and plugging the power cable in, and then pressing the power button and releasing both buttons.

Has this device ever been working normally before?

Yes it was working normally, then the next day, it just wouldn’t startup and am not sure what could’ve happened to it.

I feel like you need to RMA this device.