Jetson AGX Orin Dev Kit Not booting after 30W mode

Hello, as the title says, I switched the AGX Orin to 30W mode and after attempting to reboot, it would not power on. I have tried supplying it with more power (30W Power Adapter) but am still not getting any results. Any help would be highly appreciated.


Do you mean even the power LED is dead or power LED is still there but you cannot see anything on screen?

The power LED is totally dead. It only lights up for a moment when I click it but does not stay on.

Can it enter recovery mode? How about to reflash it? Is it possible to read the input current from power supply? Looks like some components are broken, the input current value might be able to show that.

It does not enter recovery mode, I have tried by holding the middle button, pressing the right button then pressing the left button as instructed but nothing happens.

Reading the current it shows only small amounts of current passing through at the moment that I press the button (0.02 A, 0.05 A) but then immediately goes back to zero.

I have not tried reflashing it, how would I do that?

Please follow this guide to do flash: Flashing Support — Jetson Linux<br/>Developer Guide 34.1 documentation

You mean after holding the recovery button and power on, there is no recovery usb device coming out and can’t flash the board? If so, the devkit might be damaged.

Yes thats the issue im having, only a flash of light and then it turns off immediately.

Any ideas on what the issue might be?

In the case it cant be fixed at all, is there a way to recover the memory in the jetson?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.