New Jetson AGX Orin does not boot - LED remains off

Dear Development Colleagues,

I unboxed my new Jetson AGX Orin unit and tried to turn it on. I plugged in the USB-C from the power supply into the USB-C-Port above the DC Power Input. That worked fine on my other Orin device.
Unfortunately the power LED remains switched off, despite I pushed the power button. I also tried to force the device into recovery mode without success.

Is the hardware dead or is there a bootloader missing? Or do I miss an other important point? Also Jetpack 5 SDK does not recognize the device.

Please help me to figure out this issue.

S. K.

Do you mean you can power up another Orin devkit by same USB-C supply and setting? Can you try DC Jack supply on issue unit and observe the current if possible?

Yes, that is correct. The DC Jack does not work too. After a few hours of investigation I reached the point, that the device must be defect.
The issue is from my point solved.

Thanks :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.