cannot install driver correctly for tesla k80

Hi,
I have some problems about the tesla k80 driver on my own-built workstation.
I have two cards in my computer, one is for video output(since i don’t have the integrated graphics card on my mother board), the other is tesla k80 for computing.
As i install the k80’s driver, the driver manager always say ‘This device cannot find enough free resources to use (code 12)’. I try to fix the problem by clearing the CMOS of the motherboard and rebuilding the system, but it can’t work. The system is win10 for workstation pro. And I have enabled the Above 4G Decoding on the motherboard.

the motherboard: Asrock x99 extreme4
CPU: e5 2690v3
memory: DDR4 2133MHz 128G RIMM

even if you get it working, k80 requires server flow-thru cooling. Unless you’ve taken extraordinary measures, it is likely to overheat in a workstation

Tesla products are only recommended to be used in an OEM certfied system for that product.

hello @hamburgers1626, I have (or I am going to have) a similar issue soon and I am wondering if you solved the problem or not. I have the same MB, same DDR4 RAM, similar CPU E5-2699v3 and I want to install a second-hand Tesla K80 for my research activities. I currently have a Quadro K6000 for video output and Tesla K40 for GPU computation. I was evaluating an upgrade with K80 (to be actively cooled with some mods as seen on Youtube). Now I am afraid it cannot work due to some MB limitations. Can you please provide an update on your issue ? Did you succeeed in the end ?

I have solved the problem in the end by connecting the provider of my MB. They provided me with a special bios. After the installation, the problem disappeared.