Cannot install libopennmpi-dev For Jetson Nano 2GB

I cannot install libopennmpi-dev as your post.

loc@loc:~$ sudo apt-get install python3-pip libopenblas-base libopenmpi-dev
[sudo] password for loc:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python3-pip is already the newest version (9.0.1-2).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopenmpi-dev : Depends: libibverbs-dev (>= 1.1.7) but it is not going to be installed
                  Depends: libhwloc-dev but it is not going to be installed

I’m using Jetson Nano, R32.6.1
Can anyone support me for this issue

Looks like need install libibverbs-dev and libhwloc-dev first.

Hi shane
I have tried to install libibverbs-dev, but it error too

It’s the same error?
I think you should be able googling for the error message first.

Related post from @vision-hobbist1995 is here:

Seems that you are having trouble installing different packages as well. Not sure that your system / package manager is in a working state. If it continues to be an issue, rather than spending a lot of time on it, I would recommend backing up your work and reflashing your SD card (or a different SD card)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.