Cannot launch gdbserver

Hi,

I’ve been trying to get the debugger to work for weeks now.Today I finally got one step further by actually having the debugger launch. During launch I get the error message “Cannot launch gdbserver: all options have failed.” and “Failed to attach: Failed to start gdbserver on the device.”

I’ve found a couple of topics about the same error message but my problem seems to be slightly different. My device does connect through ADB. If I run “adb devices” from the command prompt the device is recognized and connected. When I run the debugger the application is launched on my tablet and it says “Waiting for debugger”. It never goes any further. This is alse when the error pops up in visual studio and now my device is marked as offline.

I looked through the Nsight Tegra log and found that I first get a bunch of errors saying:
“adb: error: failed to get feature set: device ‘0424516002630007f9a7’ not found”
And later I get a bunch of errors saying:
“adb: error: failed to get feature set: device offline”

It does this for all projects including the sample projects in the NDK and the ones that come with Codeworks for Android.

Here is a link to my log.
https://drive.google.com/open?id=0BxTe7Nk4oFehNkcwQjNEVkVqY2s

I’ve tried updating my drivers, updating Android platform tools, reinstalling Nsight Tegra and I’ve restarted everything multiple times.

Any help would be appreciated.

Hi timofimo,

Please, don’t give up, we’re here and ready to help.

I suggest that this issue could be caused either by a faulty USB cable/port or by some configuration problem with the ADB service on a host PC.

2017-07-10 17:04:05.4210|[ADB] Received response OKAY
2017-07-10 17:04:05.4210|[ADB] Connected to adb server
2017-07-10 17:04:05.4210|[ADB] Received response 001d
2017-07-10 17:04:05.4210|[ADB] Received response 0424516002630007f9a7 offline

2017-07-10 17:04:05.4400|3-launch: D:\NVPACK\android-sdk-windows\platform-tools\adb.exe “-s 0424516002630007f9a7 shell getprop” [D:\NVPACK\android-sdk-windows\platform-tools]
2017-07-10 17:04:05.4558|3-stderr:
error: device offline

I suggest you to try debugging your application:

  1. on the same tablet but from a different host PC.
  2. on a different Android device but from the same host PC.

Also, please do the following steps:

  1. Update your Android SDK via the SDK manager
  2. Make sure that you have installed the latest ADB device driver from Google.
    The driver files are placed in
android-sdk\extras\google\usb_driver

directory in case if you have installed the Google USB Driver Android SDK component.

It turns out it was my USB cable that was causing the problem.

Thanks for the help.