Cannot launch Nsight Graphics, connection error detected communicating with target application For unreal 5.2

I observed abnormal behavior in the material preview, therefore I need to capture a frame to examine the rendering process of the preview material in the editor window. I can launch the editor normally, but when selecting a specific project from the editor, an error occurs. I am able to capture a frame when entering the specific project, but it results in an error. How can this be resolved?
image

Hi, @swzwork

Which editor do you mean ? Are you using Nsight Compute ? Note this is forum for Nsight Compute tool.

I mean editor for unreal 5.2

Thanks ! Are you using Nsight Graphics or something else ? This is not UI for our Nsight Compute.

Sorry to bother you. I am using GPU Trace Profiler of Nsight Graphics . What Should I do? like post a new thread in the right forums?

That’s fine. I see it’s already under “Nsight Graphics” now.

Hi,

I just change the title from Nsight Compute to Nsight Graphics for making the topic clearer.

swzwork, can you detail your steps? Is your issue repro-able on some public UE4/5 projects that we can use them for reproducing your issue?

It’s weird that you meet such issue since we test UE4/5 samples regularly before release Nsight Graphics. There may be something we don’t know.

Thanks
An

Yes, I am using public version of Unreal to do this. New users can post one image only. So I only can say what I did.

  1. config connection like previous:

  2. press down Launch button, start UE 5.2 editor, it succeeded.

  3. then I select AnimToTexture2 which is a 5.2 project, it will report an error:" Cannot launch Nsight Graphics, connection error detected communicating with target application"

4.When I open the static mesh asset, It shows that I can do frame capture

  1. But when I press F11, it will show an error, which content is showed in the first image of this thread

6.When I press “确定” which means ‘Yes’ in Chinese, It will show the replay window, I can watch draw process result without any details in this tool.

Hi,

It seems AnimToTexture2 is not a public UE5 sample project (like CitySample), does this issue happen on AnimToTexture2 only? or it’s repro-able on any blank UE5 project file (like the template of UE5: First Person, Third Person, etc.)

Thanks
An

Happy New Year. I have checked it out that this project is a default project of Third Person, and I tried on a totally new default Third Person project, same error happened again.

Hi,

Yes, I can repro this, an internal case had been created for tracking this.