Cannot run CUDA applications on GTX 1060 under Windows Server 2008 R2

New dedicated server with 2 x GTX 1060, Windows Server 2008 R2 64bit

Installed Geforce Experience and CUDA Toolkit 8.0 for Server 2008 R2

2 GTX cards show up in device manager as “nvidia gegorce gtx 1060 6GB” in display adapters

GPU-Z shows those cards but without CUDA support.

When I run deviceQuery sample it returns

deviceQuery Starting…
CUDA Device Query (Runtime API) version (CUDART static linking)
cudaGetDeviceCount returned 30
-> unknown error
Result = FAIL

I have tried both 369.30 driver from CUDA package and latest 376.33 from Geforce, same result

Logged in as administrator with remote access via TeamViewer 12 (have also tried Remote desktop and VNC)

Please help, how can I get this to work?

what is the output of

nvidia-smi

can you hook up a display directly to one of the cards to get a windows desktop, with a keyboard plugged into a USB port, and repeat your test there? It would help to identify whether the remote session is the issue

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Failed to initialize NVML: Unknown Error

Nvidia control panel does not start via Remote Desktop, via Teamviewer crashes with Exception Code: 40000015

Unfortunately there is no way to connect monitor, it is server in remote 3rd party data center.