Cannot run CUDA w/ 259.12 driver and Quadro 5000

Hello there,

I bought a brand new Fermi-based Quadro card (Quadro 5000) about a week ago and tried to use it with the latest Quadro Driver for 64-bit Windows 7 (259.12 released on August 2, 2010). But it cannot run a CUDA kernel function I wrote a few months ago.

The code was developed using CUDA Toolkit 3.0 and was working correnctly with a Quadro FX 4800 on the same machine and OS. I restored the old card (FX 4800) but the code still didn’t work. It seemed that the kernel function did nothing at all. I uninstalled the driver and reinstalled an old driver (197.85 released in May). Then, it worked with no problem.

I used the same binary (exe file) on both GPUs. So my guess is that the cause of this strange phenomenon is the latest driver. Since the old driver doesn’t support Quadro 5000, I cannot use CUDA with the new video card. Is there anyone who has experienced the same problem?

My environment is:
OS: 64-bit Windows 7 Professional
CPU: Xeon X5670 @ 2.93GHz x 2
RAM: 12 GB
GPU: Quadro 5000 and Quadro FX 4800
CUDA: Toolkit 3.0. I don’t use CUDA SDK.
IDE/Compiler: Visual Studio 2008 w/Windows SDK 6.0A, Visual C++ compiler for x86