Cannot run omni.isaac.gym example


I cannot run any of omni.isaac.gym and OmniIsaacGym (from github) examples on my computer. As I turn off the headless mode, the simulator appears but nothing appears on the simulator.

On the other hand, I can open the isaac-sim simulator from the launcher and run the isaac examples. This is quite strange because I was able to run any of the examples mentioned above previously without any error message, and from Noveber 14th I started to get this error.

As shown in the attached file, the error I am getting is following:
2022-11-16 19:22:18 [2,083ms] [Error] [carb.glinterop.plugin] OpenGL Interop is not available. Upgrade your driver to latest for this feature.
I get this error message when I open the isaac-sim simulator.

My computer spec is following:
OS: Ubuntu 18.04 (dual-boot)
Graphic card: Geforce 2060(Laptop)
Nvidia-driver: 515.76

If you need any further information, please let me know

kit_20221116_200045.log (523.9 KB)

I also tried downgrading the Nvidia-driver to 470.141.03 , but I am getting the same error…

Based on “CUDA 11.6 OpenGL interoperability broken?”, I run my python script as “__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia python”. Then, the error message regarding OpenGL is gone. However, still the program does not run regardless headless mode is on or off. It stops at the point saying “app ready” or “Simulation App Starting”.

I also tried “sudo prime-select nvidia”. So, I don’t need to put “__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia” to remove the error msg, but still the program is not running…

I also attached the log file. It does not show any “error” message. Maybe few “warning” messages, which, however, I’ve seen when it was actually working.
kit_20221117_133729.log (467.2 KB)

Hi there,

Did you happen to have an upgrade for your driver or CUDA versions since the last time you had it working? If so, it may be good to try reverting the versions or upgrading to the latest version. I believe the minimum recommended driver version on Linux is 470.57.

I’ve tried with 515.76, 515.65, 470.141, but all of them were not working and had the same issue (grey screen & nothing appears) I am planning to further downgrade the version. Maybe like 510.

So I tried “__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia” and “sudo prime-select nvidia”. But, it seems like Isaac-sim is not recognizing my NVIDIA GPU. There might be some error on the device mapping as it still shows my intel UHD Driver?

So, after doing sudo prime-select nvidia, I did “sudo sysctl -w dev.i915.perf_stream_paranoid=0”. I guess nvidia driver has to be prioritized while intel driver support is enabled. Also, cartpole example’s cuda device is set to device 1, so this also need to be changed to 0.

And, now it is working!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.