Failed to create any GPU devices, including an attempt with compatibility mode. on Linux

I have a problem with Launch by Isaac Sim. It has worked until now, but after the last restart of the machine, I can no longer launch it. Can anyone help me?
launcher.log (377.6 KB)

do you solve the problem? thanks

Are you using Windows or Linux? What driver version do you have installed?

Reboot the machine to fix this issue.

I faced this issue on Ubuntu 22.04 with Isaac Sim 2023.1.1 suddenly stopping and throwing the above error when I tried to launch the app again. This problem seems to have been reported several times in this forum but without a conclusive solution posted anywhere.

After deciding to reinstall the driver, I ran the nvidia-smi command to identify the driver version only to realize that even that throws an error. Going down that rabbit hole, I found this answer on Stackoverflow that recommended restarting the computer and alas, that worked!

The cause of the issue is still unknown. I wasn’t trying to install anything when the issue came up and there was no update to Omniverse or Isaac Sim before this. But I am still relieved to not have spent hours trying to figure out this problem. NVIDIA might be better off adding this to FAQs somewhere.