Isaac Sim 2022.2.0 installation problem on Ubuntu 20.04

I have been trying to install Isaac Sim on Ubuntu 20.04.5.

Initially, it got stuck at Then, when a terminal window popped up during the post install, I closed it (as suggested in another post) and after a long time the installation finally finished. However, when I try to launch Isaac Sim, the button says “Launching…” for a couple of seconds and then it aborts the process and goes back to saying “Launch”.

I noticed that after the Isaac Sim installation, Nucleus is not running and when I try to start it, I get the following error in the logs:

error while initializing database 'meta'

and then goes back to the stopped state.


  • ASUS M16 (2022) Laptop
  • RTX 3070 Ti 8GB
  • Intel Core i9 12th-gen
  • Dual boot (Win 11 & Ubuntu 20.04)

Other info:

  • No external monitor
  • Did not try to go full screen before everything is loaded
  • Of course I followed the setup instructions and installed Nucleus and Cache.
  • I was able to install Create and Code but they do not launch either.

Could it be that my system is not actually using the NVIDIA graphics card and is instead using the integrated Intel graphics?

  • When I tried to install the Nvidia drivers from the official website using a .run file, I was greeted with a black screen and couldn’t boot so, I went back to sudo ubuntu-drivers autoinstall.
  • Driver: nvidia-driver-525-open (525.78.01)
  • Kernel version: 5.15.0-60-generic
  • Boot flag: nomodeset

In Prime Profiles, the “NVIDIA (Performance mode)” is selected and

$ prime-select query


$ nvidia-smi
No devices were found

$ nvidia-settings


shows that NVIDIA is selected but no other information is displayed,

and in the About section of the system Settings, instead of Nvidia graphics, I get llvmpipe:

I’ve reinstalled my OS twice to make this work but still no hope. (47.2 KB)

Nucleus.log (939.8 KB)

Hi Please see our Driver Requirements page.

  • See Linux Troubleshooting to resolve driver installation issues on Linux.
  • We recommend installing the Latest Production Branch Version of the NVIDIA GPU Driver using the .run installer on Linux.

Try reinstalling your drivers using the .run installers. nvidia-smi should detect your GPU before Isaac Sim or any Omniverse apps could install and run.

You may need to disable the intel graphics on bios or blacklist the nouveau drivers.

Do you see any issues installing Isaac Sim from the Launcher on Windows?

Thank you for your response. After looking at this more, I do realize that my system is indeed not using the Nvidia graphics card and it could be the drivers.

I did try the latest production branch version using the .run installer (following the steps in the “Linux Troubleshooting” link) but I got a black screen with a blinking cursor and couldn’t boot.

The “Driver Requirements” page for Isaac Sim suggests 525.60.11 for Linux, although the latest production branch version is 525.89.02. Does this mean that the latest production branch version should not be used and instead the recommended 525.60.11 should be used?

There were no issues installing Isaac Sim on Windows. However, I need to install it on Linux so I can utilize ROS.

I will post to the Graphics/Linux topic as it now seems more appropriate and will update here if I resolve my issue.

Thank you

The 525.60.11 driver was recommended for 2022.2.0 since that was the latest at that time that we do testing on.

Any later drivers should be fine too.

I would recommend looking online for instructions specific to your laptop to get the Drivers installed.

I was finally able to run Isaac Sim! The issue was indeed that my system was not using the dedicated Nvidia graphics card.

For completeness, these are the steps I followed:

  • Installed the Liquorix kernel
  • Installed mesa-utils ( sudo apt-get install mesa-utils)

Still using the latest driver from “Software & Updates” not from the .run installer (since I couldn’t boot after using the .run installer)

However, there seems to still be a problem with the driver (?) since even though “Performance Mode” is selected, it actually uses “On-demand Mode”. But by right-clicking on Omniverse and selecting “Launch using the Dedicated Graphics Card”, I am able to use Isaac Sim.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.