Isaac Sim installation fail Command failed: /isaac_sim-2021.2.1/"

I installed a VM Ubuntu 18.04 to a Redhat host server.
Omniverse is installed on the VM, but i can not Isaac Sim with omniverse.
I already deleted /isaac_sim-2021.2.1 and retry but it don’t work.
Do i need to change the driver ?

nvidia-smi give :
Thu Jan 20 12:20:54 2022
| NVIDIA-SMI 470.86 Driver Version: 470.86 CUDA Version: 11.4 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 Quadro RTX 6000 Off | 00000000:07:00.0 Off | Off |
| 32% 34C P0 1W / 260W | 0MiB / 24220MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| No running processes found |

launcher.log (77.7 KB)

And i can not update openGL, i have opengl 3.3 and i need opengl 4.6

glxinfo | grep ‘version’
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
Max core profile version: 3.3
Max compat profile version: 3.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.1 Mesa 20.0.8
OpenGL shading language version string: 1.40
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
GL_EXT_shader_implicit_conversions, GL_EXT_shader_integer_mix,

i used this command to update openGL
sudo apt-get install freeglut3

Thank You.

Hi, are you able to install and run Create or any other Omniverse apps?

The GPU and driver looks OK. Please check if Vulken is working too.

hi, I try to install other omniverse apps, I try to install and launch Create.
and it’s correctly installed, but when i launched it, I have this screen and I am block here, I don’t have anything appear.

I try launching with the .sh file :
and i have this error output and the same screen at the screenshot :
omni.create.singlegpu (2.7 KB)

I test vulkan by typing vulkaninfo | less and i have this outpout:
vulkaninfo (2.9 KB)
I thing Vulkan work correctly.

And I try other resolution i found in this forum, I try 4 files to see what they give :
this is all the errors they give to me :

isaac-sim_sh (8.8 KB)
isaac-sim.headless.websocket (28.7 KB) (312 Bytes)
omni.isaac.sim.warmup.txt (26.3 KB)

Yes, and by the way, I am in a Ubuntu 18.04 wayland session because the 470.97 driver generate problem to log in a Ubuntu normal session, i have a Ubuntu user log in loop.
Sorry for this big reply but i really need help,

Looks like Isaac Sim is running in headless mode only. Both the warmup script and WebSocket mode looks OK.
Try running using again and connect it it using the browser. See: Livestream Clients — Omniverse Robotics documentation

Do you have a monitor connected to the VM (virtually on VM but physical on host)?
Try running xrandr.

Hello, first tank you very much, I could solve some problem.
I am not sur if I understand correctly, so isaac sim work and launch but don’t display anything in the screen of my monitor.

I don’t have a monitor directly connected to the serveur gpu ouput port. but I am connected to the server with ILO5 graphical display HTML5 console, so I am remotely connected to the server. And on this server with redhat host os, I created a virtual machine with virt-manager (qemu-kvm) with a ubuntu 18.04 guest os. And also, I am remotely connected to the virtual machine, with the ILO5 graphical display HTML5 console, or ssh terminal. i don’t have a display directly connected to the server graphic card output displayport

ok, now, when I launch isaac-sim.headless.websocket and I open a browser, whith my ip, I have isaac sim software open, it’s works, but now my question is why I can’t open, when i connect a display on the gpu of the server. and why I don’t have the isaac sim launch in Omniverse. I don’t understand.

and I have an other question, if isaac is correctly installed, so why on omniverse library I don’t have isaac and the launcher button of isaac, I can only launch isaac why command line ?

and the result of xrandr
when is was connected remotely ssh terminal :
Can’t open display

when I was connected remotely with virt-manager :
Screen 0: minimum 320 x 200, current 2488 x 976, maximum 8192 x 8192
XWAYLAND0 connected 2488x976+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
2488x976 59.91*+

but finally i have isaac sim displayed with websocket, so it’s ok.
Thank you.

and I have an other question, if isaac is correctly installed, so why on omniverse library I don’t have isaac and the launcher button of isaac, I can only launch isaac why command line ?

It looks like the installation was not completed because of the error during post install. There maybe be leftover files during the install but the folder will be deleted when you try to install it again. You could also try deleting that folder before a reinstall.

There could also be some issues with the VM like X forwarding or drivers. Can you try creating an Ubuntu 20.04 VM instead and also try other driver version like 495.

ok I understand that the installation went wrong. I found some posts on the forum with people having the same problem. I did what was advised, such as manually deleting the isaac folder and downloading it again, I did this several times, and it didn’t work, I still got the same error.

I also tried cleanup-tool, but without success I have the same problem with Ubuntu 18.04 virtual machine.

I will try as you asked me with Ubuntu 20.04 and driver 495.

But to be sur, you don’t advice using a virtual machine with isaac Sim or Omniverse, not because it’s impossible but it’s not sur to be stable. you advice using an OS directly installed to a hard drive machine ?

Hello, I created a Ubuntu 02.04 virtual machine, I purge an clean all NVIDIA driver, i put nouveau driver in blacklist.
I download and install the driver 495.46 like it’s recommended here

And I have this problem now, my VM is lock like this and i can just connect remotely with ssh or activate TTY2 but I can not log with the graphic login user.

it seem that the driver is correctly install but, i have a black screen problem. But if i uninstall the driver it’s ok, i can log with graphical interface.

Thank you for your help.

Yes, we do not recommend using a remote VM with windowed mode. We do not have a stable solution for this. The best experience would be to run natively with a display attached.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.