Isaac Sim does not open from Omniverse GUI. When I try the command line mode, it fails with an error

I tried to open the latest version of Isaac SIM through Omniverse by this GUI below:

There are three versions installed in this window. None of the versions work in my machine.
You might very well suggest that I shouldn’t have at first installed three versions in my machine. But I only had the latest version (2021.2.0) installed at first. It failed to launch. Hence I installed 2021.1.1. Even that failed to launch. So I installed 2021.1.0. Even that doesn’t work.

When I click on the ‘Launch’ button for every version, it says ‘Launching’ but nothing really happens afterwards. So I tried to manually launch it from the command line by using the following command:

/home/arun/.local/share/ov/pkg/isaac_sim-2021.2.0/ -v

However it fails with the following error.
isaac_sim_errors.txt (213.7 KB)

Like usual, you might be interested in my nvidia-smi. The output is below:

I have no luck running Isaac SIM. Your software are very buggy. This is not the first time I have faced problems with Isaac SIM. I got completely frustrated with Isaac Sim back in March, 2021 because of a chain of issues in just starting up Isaac SIM. Now I try after 9 months, hoping that your software might have become better. It is still the same old bugs.

Hi, it could be an issue with the 495 drivers. Please try the 470 drivers.

@user77600 the issue is that you are running an xserver on the second GPU but by default isaac sim tries to use GPU 0

and fails when trying to create the window:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  226
  Current serial number in output stream:  224

Can you try using --/renderer/activeGpu=1 when starting

Alternatively, plug your monitor into GPU 0 so nvidia-smi shows Xorg running on GPU 0 and try running isaac sim again

@Hammad_M This solution does not solve the problem

Can you please provide the log when running with --/renderer/activeGpu=1

Here it is

renderer_activeGpu_log.txt (212.1 KB)

From the logs it looks like you tried:
can you try with --/renderer/activeGpu=1 (the extra slash after the two dashes)

And did anything change if you plugged your monitor into the first GPU so the xserver also ran on the first GPU?

Another option is to run headless with livestream, which should workaround the issue of the app not being able to open a window.

Doesn’t work with that option neither. Logs below:

renderer_activeGpu_log.txt (278.0 KB)

one more thing to try:
--/renderer/activeGpu=1 --/renderer/multiGpu/enabled=true

both GPUs should show up in the logs here if they are configured correctly,

| Driver Version: 495.29      | Graphics API: Vulkan
| GPU | Name                             | Active | LDA | GPU Memory | Vendor-ID | LUID       |
|     |                                  |        |     |            | Device-ID | UUID       |
| 0   | Quadro RTX 6000                  |        |     | 24822   MB | 10de      | 0          |
|     |                                  |        |     |            | 1e30      | 6eaf1850.. |
| OS: Linux US7957PC, Version: 5.4.0-90-generic
| XServer Vendor: The X.Org Foundation, XServer Version: 70000000 (
| Processor: Intel(R) Xeon(R) Platinum 8260 CPU @ 2.40GHz | Cores: Unknown | Logical: 96
| Total Memory (MB): 257585 | Free Memory: 201820
| Total Page/Swap (MB): 392998 | Free Page/Swap: 392998

What is the output of vulkaninfo and xrandr?, i’m trying to understand what is special about your configuration where only the first GPU is seen by that process.

I had a similar issue and was able to fix it in the following way. First open up a new terminal and use the following command export MESA_GL_VERSION_OVERRIDE=4.6. Afterwards in the same terminal launch Isaac Sim with the normal command you used in your first post. This overrides the OpenGL version that is used which fixed the problem on my machine.

arun@US7957PC:~/.local/share/ov/pkg/isaac_sim-2021.2.0$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1536 x 801, maximum 1920 x 1200
default connected 1536x801+0+0 0mm x 0mm
   1024x600      60.00  
   320x240       60.00  
   640x360       60.00  
   640x480       60.00  
   800x480       60.00  
   800x600       60.00  
   1024x768      60.00  
   1152x864      60.00  
   1280x720      60.00  
   1280x800      60.00  
   1280x1024     60.00  
   1360x768      60.00  
   1440x900      60.00  
   1600x900      60.00  
   1600x1200     60.00  
   1680x1050     60.00  
   1920x1080     60.00  
   1920x1200     60.00  
   1536x864      60.00  
   1536x801      60.00*

Vulkaninfo output in this text file below:
vulkaninfo.txt (41.3 KB)

VulkanInfo only shows GPU0 has vulkan installed, but nvidia-smi shows that GPU1 is running the Xserver.

In order for isaac-sim to start in non-headless mode with this setup there needs to be one GPU that has both available… Is there anything special about how the two GPUs are configured with your setup? Any environment variables etc?

I don’t know how to answer that question

Fair, I’ll pose the questions in a different way:

Can you run the x server / physical display from the first GPU?
Can you remove the second GPU temporarily, does anything change?

It is a remote server accessed via x2go client on a local machine via the internet. I can’t change any GPUs

If its a remote machine then I would highly recommend using one of the livestream clients like:

x2go does not support vulkan as far as I am aware so it will not be able to create/show the isaac sim window.