Isaac-sim installation is failed due to X Error

hello members of the NVIDIA forums,

Would you tell me that I should do for installing Isaac-sim ?

I tried preparing Isaac-sim based on the official documentation.

I completed “2.1 Workstation Setup”.
Then, I tried installing Isaac-sim based on “2.2 Omniverse Launcher”.
However, I faced the following error about X server:

I guessed that the error is raised on multi GPUs.
I tried to search related questions in the forum, however I could not find the answer.
My PC has six GPUs(Geforce RTX 3090).

==== error messages. ( was manually written.) =====
15:09:48.186 › Running “/home//.local/share/ov/pkg/isaac_sim-2022.1.1/”
15:09:49.082 › Dequeue [0b641047-f3c8-4b3d-8637-085f7fb08afb] isaac_sim.
15:09:49.083 › Reset current installer.
15:09:49.083 › [0b641047-f3c8-4b3d-8637-085f7fb08afb] Removing the artifact path /home//.local/share/ov/pkg/isaac_sim-2022.1.1/Isaac due to an error.
15:09:49.734 › [0b641047-f3c8-4b3d-8637-085f7fb08afb] Removing the installation path /home//.local/share/ov/pkg/isaac_sim-2022.1.1 due to an error.
15:09:51.548 › Error: Command failed: “/home//.local/share/ov/pkg/isaac_sim-2022.1.1/”
X Error of failed request: GLXBadFBConfig
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 0 ()
Serial number of failed request: 194
Current serial number in output stream: 194
2022-10-13 06:09:48 [705ms] [Error] [omni.core.ITypeFactory] ITypeFactory must not be destructed post-main. plugins will not be unloaded.
/home//.local/share/ov/pkg/isaac_sim-2022.1.1/ line 17: 3774483 Segmentation fault (core dumped) ${SCRIPT_DIR}/

at ChildProcess.exithandler (node:child_process:407:12)
at ChildProcess.emit (node:events:527:28)
at maybeClose (node:internal/child_process:1092:16)
at Socket.<anonymous> (node:internal/child_process:451:11)
at Socket.emit (node:events:527:28)
at Pipe.<anonymous> (node:net:709:12)

Hi. I’m curious if you have similar issues running Create or Code.
Please also share the Isaac Sim logs at ~/.nvidia-omniverse/logs/Kit/Isaac-Sim/2022.1
Do you have a display connected to one of your GPUs?
An output of your nvidia-smi may be helpful too.

Thank you for your quick reply.
Could you tell me how to run “Create” or “Code” ?
Are these the process in the installation ?

[about log file]
I share a log file in ~/.nvidia-omniverse/logs/Kit/Isaac-Sim/2022.1/.
kit_20221013_152650.log (352.7 KB)

[about display]
Yes, I have a display connected to one of my GPUs.

[about nvidia-smi]
I share a text file for nvidia-smi outputs.
nvidia_smi.txt (5.7 KB)

Create is another app on the Omniverse Launcher. Please try install and run it.

If you are not able to run any other Omniverse apps, there could be a problem with your drivers. Try reinstalling it.
See also: Linux Troubleshooting — Omniverse Robotics documentation , were you able to resolve the issue related to installation?

I’m sorry for late reply.
I installed “Create” and “Code”, however I couldn’t run them.
Does the running problem depends on the driver ?

Sheikh_Dawood recommends to update my driver.
If the running problem depends on my driver, I would like to close the issue.
Because I can’t try to update the driver due to relationships of other apps.

I tried to install “Create” and “Code” from Omniverse Lanucher.
The installations were normally finished.
Then, I click the launch button of “Create” or “Code”.
However, I couldn’t run these apps.
(The apps didn’t show the main window of them.)

The following logs show the installation message and running message.

[When I installed and tried running “Create”. I had no response after the final log message.]
14:34:32.166 › [e802e298-e2f5-4ce3-a288-21bd621a0e6b] Finishing the create@2022.2.2 installation…
14:34:32.170 › Set create version to 2022.2.2.
14:34:32.173 › Dequeue [e802e298-e2f5-4ce3-a288-21bd621a0e6b] create.
14:34:32.173 › Reset current installer.
14:34:32.173 › [e802e298-e2f5-4ce3-a288-21bd621a0e6b] Installed create@2022.2.2 to /home/my pc/.local/share/ov/pkg/create-2022.2.2.
14:34:53.078 › Running “/home/my pc/.local/share/ov/pkg/create-2022.2.2/”

[When I installed and tried running “Code”. I had no response after the final log message.]
14:45:35.087 › [ff1db872-faa7-47a9-ad18-61a4b2f60fce] Finishing the code@2022.2.0 installation…
14:45:35.089 › Set code version to 2022.2.0.
14:45:35.091 › Dequeue [ff1db872-faa7-47a9-ad18-61a4b2f60fce] code.
14:45:35.091 › Reset current installer.
14:45:35.091 › [ff1db872-faa7-47a9-ad18-61a4b2f60fce] Installed code@2022.2.0 to /home/my pc/.local/share/ov/pkg/code-2022.2.0.
14:45:44.150 › Running “/home/my pc/.local/share/ov/pkg/code-2022.2.0/” --/app/environment/name=‘launcher’

Yes, please follow Sheikh’s instruction and update the drivers. If the issue still persists then you can always reach out to us.

Launching Omniverse with MESA_GL_VERSION_OVERRIDE=4.6 ./omniverse-launcher-linux.AppImage as proposed by wine - X Error of failed request: GLXBadFBConfig - Ask Ubuntu has helped me to temporarily solved the issue. I am following the discussion for getting a cleaner solution.