Isaac Sim 2022.2.0 launch failed

I installed the Isaac Sim 2022.2.0 when the Isaac Sim 2022.1.1 had not yet been deleted. After install finished, Isaac Sim 2022.2.0 did not start correctly, with errors on the terminal. In the end, the terminal suddenly closed.

Here is my monitor video and latest log.

kit_20230111_150613.log (473.0 KB)


[2023. 01.11. added]

Thanks to above mention, I can launch Isaac Sim via terminal, but still cannot launch via Omniverse launcher. I share you my logs which were successful launches and a failed launch.

I am using only one GPU, but the two were detected for a reason. In a successful launch, only one GPU was detected correctly. However, there are several warnings in the successful launch logs. Will it cause problems?

The failed log says the problem was caused by ‘Multiple Installable Client Drivers.’

[gpu.foundation.plugin] Multiple Installable Client Drivers (ICDs) are found for the same GPU on the system. This causes the same GPU to be reported multiple times by more than one driver and leads to instability or crash.

For NVIDIA drivers, please follow troubleshooting docs to uninstall and completely purge Linux-distribution-provided driver packages, and then reinstall your driver cleanly via .run package. Otherwise, updating Ubuntu software may reinstall a secondary ICD or override the existing NVIDIA driver.

To verify the proper NVIDIA driver installation, only one of the following icd.d folders should contain nvidia_icd.json file:

/etc/vulkan/icd.d: Location of ICDs installed from non-Linux-distribution-provided packages

/usr/share/vulkan/icd.d : Location of ICDs installed from Linux-distribution-provided packages
...
...
...
...
|---------------------------------------------------------------------------------------------|
| Driver Version: 525.60.11     | Graphics API: Vulkan
|=============================================================================================|
| GPU | Name                             | Active | LDA | GPU Memory | Vendor-ID | LUID       |
|     |                                  |        |     |            | Device-ID | UUID       |
|---------------------------------------------------------------------------------------------|
| 0   | Intel(R) Graphics (ADL-S GT1)    |        |     | 48063   MB | 8086      | 0          |
|     |                                  |        |     |            | 4680      | 84e7c1f5.. |
|---------------------------------------------------------------------------------------------|
| 1   | NVIDIA GeForce RTX 3090          | Yes: 0 |     | 24822   MB | 10de      | 0          |
|     |                                  |        |     |            | 2204      | be8d84b5.. |
|---------------------------------------------------------------------------------------------|
| 2   | NVIDIA GeForce RTX 3090          | Yes: 1 |     | 24822   MB | 10de      | 0          |
|     |                                  |        |     |            | 2204      | be8d84b5.. |
|=============================================================================================|
| OS: Linux bak-ubuntu, Version: 5.15.0-57-generic
| XServer Vendor: The X.Org Foundation, XServer Version: 12013000 (1.20.13.0)
| Processor: 12th Gen Intel(R) Core(TM) i7-12700K | Cores: Unknown | Logical: 20
|---------------------------------------------------------------------------------------------|
| Total Memory (MB): 64085 | Free Memory: 46799
| Total Page/Swap (MB): 2047 | Free Page/Swap: 2047
|---------------------------------------------------------------------------------------------|

1 Like

Hi. Try doing a clean install of the drivers. See Linux Troubleshooting — Omniverse Robotics documentation

I already cleaned the installation of the drivers and Isaac Sim, but it didn’t work. Though I tried again to refer to your shared URL, version 2022.2.0 is still not launched via Omniverse launcher.

Version 2022.1.1 works well.

I have the same problem with version 2022.2.0

@psh9002 @v.sury Are you able to launch the latest Create and Code?

@Sheikh_Dawood I can launch Isaac Examples from GUI and also can launch RL examples.

I think the problem, launching via Omniverse launcher, only occurred.

This is the same case with me. When you launch the latest version, a black screen pops up and that’s it. It doesnt even reach the option of “Headless, Headless(websocket)…”. The previous version does work though.

Try delete the /etc/vulkan folder before reinstalling the drivers.

@v.sury Can you share the Isaac Sim App Selector or Isaac Sim logs?
There is also a post-install log that could show any errors.

Here is the latest log.
kit_20230118_083717.log (249.6 KB)

Thanks for the log.

It looks like Isaac Sim is not loading the renderer correctly. Can you try disabling the 1080 Ti or pull it out and test if it runs with just the 3080?

But the active GPU is 3080 and not 1080Ti. I doubt if 1080Ti is supported in the first place. How does it help to disable the 1080Ti?

Also, running the isaac_sim_headless.sh results in a core dump.

Having both the 3080 and 1080 connected may cause issues with device detection. Try using the flag to select GPU device in this guide.
https://docs.omniverse.nvidia.com/app_isaacsim/prod_kit/linux-troubleshooting.html#q9-how-to-specify-what-gpus-to-run-omniverse-apps-on

1 Like

kit_20230120_164452.log (249.5 KB)

Still the same result.

I should try next time.
Thanks!

1 Like

I uninstalled the graphic driver then deleted vulkan and installed the graphic driver again. However, it still doesn’t work.

How can I follow the step at the Linux Troubleshooting Q9? I cannot understand well.

Nevertheless, I can run with /home/$USER/.local/share/ov/pkg/isaac_sim-2022.2.0/isaac-sim.sh as you mentioned on another page without any problems.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.