Isaac sim 2022.1 is not launching using remote access software Team viewer

I have installed Isaac sim 2022.1 on my PC. When I tried to launch Isaac-sim from the Omniverse launcher or through isaac-sim.sh script, it is not launching and throwing “X Error of failed request: GLXBadContextTag” error. I am facing a similar problem when I directly run on the my PC.
My PC configurations are,

  • Ubuntu 18.04 LTS desktop version, More than 32GB RAM and 1TB HDD
  • NVIDIA A40 GPU - 2 numbers, NVIDIA 470.129.06 driver , CUDA 11.4, OpenGL 4.6
  • Xorg 1.20, gdm3

My question is, does it possible to launch Isaac sim and develop Isaac sim applications through remote access software like Teamviewer, VNC, or Anydesk?

would you please share your error log and nvidia-smi


xorg-log_output.txt (48.2 KB)
dmesg_output.txt (181.2 KB)
syslog-output.txt (1.1 MB)

Hi,
I have attached the nvidia-smi output and screenshot of the error.

Is this the nvidia-smi while you are running Isaac Sim? It seems your GPU is not assigned to Omniverse

Hi ltorabi,

The reason it is not assigning GPU is because of kit is getting segfault during isaac-sim launch. Please find the dmesg output of the error.

How to assign GPU to omniverse ?

@hmazhar would you provide some hints on how to assign GPU, when your machine has two GPUs

@anil.antony you cannot run isaac sim directly inside of a VNC session because the VNC session is usually not GPU accelerated or has vulkan support.

The recommended option

We have a few other livestream clients you can also try, each has its own .sh and associated client listed on the above documentation.

Or:

  • use x11vnc to expose your physical display over VNC which will be accelerated. This is not well documented online but might be an option to try if livestream is not an option.

Hi @Hammad_M ,
Thank you very much for the help. I am able to launch Isaac-sim using headless mode. Also, I tried with remote software (MobaXterm) which supports x11 forwarding and it is also working.

1 Like