Cannot see "Start CUDA Debugging (Legacy)" in Nsight Visual Studio Edition

I am coding with CUDA 12.1 and RTX 2060 on Windows 11 (driver version: 531.79, not with WSL). It is my only card, so I suppose only legacy debugging mode is supported. I am also following the guide at Getting Started with the CUDA Debugger :: NVIDIA Nsight VSE Documentation, but things don’t add up:

(right-clicking the project → Debug in Visual Studio)

(Nsight Monitor)

As shown, no “Start CUDA Debugging (Legacy)” exists in the Nsight Visual Studio Edition menu. Launching the host local Windows debugger will not pause at breakpoints set in the kernel as expected. Also in Nsignt Monitor, there are fewer options. Any ideas to continue with my debugging? Thank you.

You have a Turing GPU. See here. The Legacy debugger never had support for Turing GPUs.

Not correct. The next gen debugger on pascal and newer GPUs can use preemption to permit single GPU debugging.

There is a separate forum for Nsight VSE questions. I suggest asking further questions of this type there.

1 Like

Thanks. Let me try again after enabling TCC mode.

If it’s your only GPU, you won’t be able to enable TCC mode. Furthermore, GeForce GPUs do not support TCC mode. Not sure why you want to enable TCC mode. I suggest asking questions like this on the Nsight VSE forum.

I thought the next-gen debugger only worked with TCC mode.

The alternative method I used is to switch to Linux and continue. It went smoothly.