Cannot set terminal process group (-1): inappropriate ioctl for device

Hi, Team!
I have such error:

How to solve that ?

Since you only provide a screenshot, I can only say please reflash your board with sdkmanager.

And that’s all?
I worked on that image 3 weeks… Maybe you can propose any other solution?
I rebooted Jetson and saw such error.
df -h show only /dev, it doesn’t see microSD card.
If I ran lsblk - commad not found.
If I run sudo cat /boot/extlinux/extlinux.conf - no such directory …

Hi,

Then you could learn how to dump serial console log.

Basically, this situation is your device tries to mount roofs from a non-exist location. For example, it tries to mount from usb drive, but there is totally no such thing on device.
It cannot find rootfs so it fallback to initrd. That is why bash4.4 is shown on screen.

I will add that a serial console boot log is very important. Not only does it say what goes on in Linux, it also says what goes on with setup during boot stages. Serial console runs from a host PC, and so it can easily log everything it sees, and it sees far more than what you see on a terminal.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.