Jetson Nano suddenly boots on text mode instead of desktop mode

Hello everyone,
Im working on the Jetson Nano for almost two years for my Thesis as a mechanical engineer. this never heppend to me.


when I boot my Nano it goes to Ubuntu 18.04.3 LTS “username” tty1.
i see many errors as you can see in the image attached. i tried many thing as disabaling ASPM by doing the command :
sudo sh -c ‘echo “performance” > /sys/module/pcie_aspm/parameters/policy’
in the command line.
or i tried to download lightdm
and i tried to remove some files to increase space in disk, nothing helped.
I am a beginner in linux platform and i really tried many ways to fix it, i would be very glad if someone can take a look at my problem and help me. It will help me finish my thesis in time.
I even tried to make an but i didnt understand what’s wrong. the report:

Thanks alot!

I hate to say it, but trying to reinstall lightdm might have caused more harm than good (lightdm and any desktop GUI environment has a lot of configuration involved, most of which was probably destroyed or overwritten). Is it correct that this is an SD card model of a dev kit? Meaning it does not have eMMC, and is not a third party carrier board?

One thing I’d consider is to start by cloning the original SD card and not further destroying it if you have content on it you want to save.

Whenever you do have an issue, then I strongly suggest a serial console log. Logs such as that work even in boot stages before Linux ever starts, and can log to the host PC to make reports easier. A serial console log is really needed. Knowing if you can log in via serial console is also a very important ability if it still works.

However, from prior screenshots, it looks like the Wi-Fi has issues, and there was some sort of thermal problem. You might want to see how things change if you remove the Wi-Fi card (I’m assuming you have a separate Wi-Fi, correct me if I am wrong).

Hi linuxdev, thank you for the quick response.

it is a jetson nano developer kit B01 model number P3450, i tried to check if it has eMMC so i tried to boot it without the SD card and it didnt show anything (and the current on the jetson was very low) so i guess it doesn’t have eMMC.

i will read more about the serial console log, im not sure if it will help me keep doing my thesis (working on ROS with Rviz). or maybe i didnt understand right?

I took off my Wi-Fi card and it actually showed less isues on booting before the tty1 text screen comes up.

But I must confess that out of desperation i tried another command (before you answered) that might got the problem worst.
I saw on Stack-overflow that due to a error of " No module named 'apt_pkg '" which was written in the second image attached to my question, I should ran this command :

ln -s /usr/lib/python3/dist-packages/ /usr/lib/python3/dist-packages/

So I ran it. Now when i boot my Nano, after showing the Nvidia logo and the errors , it doesn’t go to the tty1 and let me login (in the text screen as it was before the command). It’s just showing black screen that keeps turning on and off. like stuck in a loop.

I dont know what to do :(


first of all, if your device has an SD card slot, then it’s the SD card version. If it does not, then it’s the eMMC version. We don’t put both of them on a single Jetson Nano module.

Please do not try to further ruin the device more. I’d suggest you first back up data in the SD card (it’s easy on Linux, but you can still find tools on Windows to let you read/write ext4 partitions), and do a re-flash to your device. As you were still able to login to the system before, looks like the bootloader are still working fine, so you may just need to flash the SD card using tools like Etcher:

Otherwise, you’ll need to find a host PC running Ubuntu 18.04 to be able to flash the device using SDK Manager.

The file you added the symbolic link to does not exist. That’s a file for desktop PC architecture and cannot function on an ARM CPU. So you added a symbolic link to a non-existent library file. Sometimes, if the linker is told to link to a non-existent file or directory, it can cause user space to fail. Possibly you ran into this.

FYI, to expand on what @DaveYYY mentions, dev kits from NVIDIA which boot to SD card, and do not have eMMC, have the SD card slot on the module itself. Third party carrier boards which have eMMC and SD cards place the SD card slot on the carrier board, and not on the module. The two have very different device trees and software support. When someone says it is an SD card model, it implies the hardware is on the module, and that it cannot run without the SD card; when using an eMMC model, it implies using the third party carrier board’s software, and that boot is still normally to eMMC unless special steps were taken to put the o/s on SD (but the boot content would remain on eMMC).

If the SD card has the o/s, then you can possibly repair the mistake on a Linux PC. If not, and if this is on eMMC, then you are going to have to flash again. You could possibly clone the eMMC before flashing. There is in that case a possibility that you could edit the clone and flash that to get the symbolic link removed, but this will take significant time and disk space.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.