Unable to boot into nano

Was going through this course S3E3 Training classification models, Jetson AI Fundamentals - S3E3 - Training Image Classification Models - YouTube, I was running headless and I downloaded the images and went to run the docker command which I got an error saying I did not have account permissions. I couldn’t even shutdown the nano so I manually unplugged it, after plugging it back in it will no longer boot up.

No camera is connected , using an HDMI cable and no longer trying to run headless. All these models took a long time to download so I hope the solution is not to reflash the unit,

Latest jet pack ver 4,6
Ubuntu 18 host laptop
Jetson nano 4gb


strong text

Hi, please attach your board to a host PC, and dump log from UART connection.
(Put it as text here)
It’s hard to read your picture.

How do I do that ?

Is it this ?https://jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

Or is there a way to do it via USB ?

Yes, UART log is usually the first thing coming to one’s mind when they need help here.
Are you still at least able to login via CLI?
What is the last line of log it gets stuck on?

I will buy a cable,

I can’t get into the command line , immediately after booting its starts displaying what was show in the image above ,

It keeps running but the last line is always
[ OK ] Started D-Bus System Message Bus


If you can see the text showing up on the monitor but the UART serial cannot give you info, then it is most likely some setup error on your side for that serial. This serial console can dump log in almost every case except recovery mode and no power status.

Try to open the console before you power up the board. This log is realtime, it cannot trace back if you didn’t catch it. I mean if the log already done printing before you open the console, then you are not able to see any log.

I did have a setup error (had to swap the white and green wire) but still the same issue. I did open minicom before I powered on the unit. Still the same thing…

Try to use other tool like picocom instead of minicom and see if that makes any difference.

Please be aware that this is a basic tool that we are using everyday. So I am 100% sure if you see something on your monitor, then your serial console shall dump the log.

Same thing

I ran picocom -b 115200 -r -l /dev/ttyUSB0
then I plugged power into the device and nothing happens…

Then your cable connection could still be wrong.

Why do you connect the pin on the 40 pin header? the website already showed the uart pin is over here.

Sorry about that , I thought perhaps that was for the 2gb ver.

I got a new error though now

I ran the same command via picocom and nothing happens, I then tried minicom and got this error

minicom: cannot open /dev/ttyusb0: No such file or directory

Are you seriously asking this question? ttyUSB0 and ttyusb0

when I do sudo minicom it won’t let me change it , it just says
minicom: cannot open /dev/ttyusb0: No such file or directory

I then tried changing it via sudo minicom -s

I save it as default but the change does not stick, when I try running it here it also does not show up

However once I close this window it will default back to usb0, vs USB0

Just use picocom. It is more easier to use.

sudo picocom -b 115200 /dev/ttyUSB0

Just ran it , same thing, after I power on the board do I need to do anything ? before or after ?

Nope, it just indicates your connection is still wrong.

Are you using A02 or B01 carrier board or you don’t know what you are using?

BO1 Carrier Board

Just an example of how that log will be like.

This is just an example. Your issue is not same as this guy.

Please make sure your connection matches this.

Jetson Nano J50 Pin 4 (TXD) → Cable RXD (White Wire)
Jetson Nano J50 Pin 3 (RXD) → Cable TXD (Green Wire)
Jetson Nano J50 Pin 7 (GND) → Cable GND (Black Wire)

Make sure the color mapping is correct too. I mean make sure white wire is really RX. Green to TX.

The rest of it is check whether the board really powers up…