Can't do profiling for Maxwell with CUDA 6 RC?

Has anybody been able to get instruction counts and cycles from Maxwell GPUs?

I’ve tried both Nsight 4, but the performance counters for Maxwell are grayed out:

I’ve also tried Visual profiler, but it fails with:
Internal profiler error (8589934593:999)

Hello, can anyone help, especially from NVIDIA? (confirm it’s working or not)

Just tried… I have a bare test machine with CUDA 6 RC and a 750 Ti and I can see instruction ops in Visual Profiler (Nsight is not installed).

Let me know if you want more info.

Thanks that’s reassuring. Are you using Windows and if so, which version? I have both a GTX 690 and a 750Ti plugged in (GTX 690 is device 0 & 1). I’ll try to remove the 690 and see if it works.

Win7/x64 and the very latest driver from last week.

A most grievous mistake! I was using Visual Profiler from CUDA 5.5 instead of 6.0 !

Now it works, but Nsight still doesn’t. I’m filing a bug.

Were you able so solve the issue somehow?

Yes, I installed Nsight 4.0 RC. Apparently the one from CUDA 6.0 RC was a beta.

Is there a newer Nsight Eclipse Edition? Is that only available in a specific developer program? Unfortunately the part of the site is down right now.

The nsight 4 being referred to is not nsight eclipse edition (linux) but nsight visual studio edition (windows). For nsight visual studio edition, there is a separate developer program that you need to request access to.

Unfortunately it’s still down: https://developer.nvidia.com/registered-developer-programs

[i]Registered Developer Programs

We are in the process of a major update to the NVIDIA Developer Portal. During this time user profile changes and new signups are closed.

The URL you tried to access may require you to login or requires membership to one of our registered developer programs. If you are a member please login - using the link at the top right of the web page.

Should you want to extend your membership or sign up as a new member - we apologize for any inconvenience and request you try again in a few hours.

Thank you for visiting NVIDIA Developer.[/i]

This direct link to Nsight Visual Studio Edition 4.0 RC1 works for me:

https://developer.nvidia.com/rdp/nsight-visual-studio-edition-early-access

That one is working for me as well. I just can’t find an early access edition of Nsight Eclipse Edition but maybe there is none.