using CUDA Visual Profiler with a .lib CUDA file

Hi,

I have an executable (from a visual C++ project) which is using a CUDA .lib file. The CUDA .lib has all my CUDA functions. My code is running and giving me nice results (time and output).

Here is my problem:
I want to use the CUDA Visual Profiler with my executable, but I’m getting the following error message:.

Error -96 in reading profiler output.
No data rows in profiler output file

Do I have to instrument my CUDA code? Is there a nvcc option for this? I have tried –run, but I can’t use –lib with this option (nvcc error: more than one compilation phase specified).

Diego

I think you are not selecting any signals.
In session settings, click on configuration and check the “Signal List” box
(or manually select few signals).

I checked the signal list box but it didn’t work :no:

I tried with one of my earliest CUDA implementation and the CUDA Visual Profiler works beautiful. However, I’m getting the Error -96 with my executable which uses my .lib CUDA file.

Also I want to report that my display blinks several times when I run my executable-.lib_CUDA using the CUDA Visual profiler. It happens only during the first second of the execution.

All my mistake. It is working.

Hi…
Me too getting same problem of
Error -94 in reading profiler output

Minimum expected columns(method,gputime,cputime,occupancy) not found in profiler output file.

THe samle *.cpj files is working fine which have come with profiler. But if i try to add new project files from NVIDA_SDK release of MatrixMul i am getting this error. :(