CUDA Visual Profiler generating csv that itself cannot read

Copied from [post=“472916”]CUDA Visual Profiler generating csv that itself cannot read[/post]
CUDA Visual Profile on linux error when reading csv with # lines.

When using the CUDA Visual Profiler 1.0.11 on a program, it will generate temp_cuda_profiler_0.csv while running. The file starts out with these lines:




When finished running I get the error:

Error -94 in reading profiler output. Minimum expected columns (method,gputime,cputime,occupancy) not found in profiler output file.

If I make a copy of the temp_cuda_profiler_0.csv file while the profiler runs, and then later try to import it, I get the same error.

If I remove the lines:



it imports it correctly.

  • Operating System - Fedora 9 x86_64
  • CUDA toolkit release version: cuda-linux64-rel-nightly-2.1.1635-3065709
  • SDK release version - NVIDIA_CUDA_SDK_2.02.0807.1535_linux
  • Compiler for CPU host code - g++ 4.3.0
  • System description including:
  • CPU type :Intel® Coreâ„¢2 Extreme CPU X9770 @ 3.20GHz
  • Installed system RAM: 4G
  • System type and model: Alienware ALX
  • Video cards installed in the system: 3 GTX280s

I think the problem is that you have moved to a newer version (2.1) of CUDA toolkit and driver - but you are still using the older version (1.0) of CUDA Visual Profiler. You should move to using CUDA Visual Profiler v 1.1. Let me know if this solves the problem.

Yes, that was the problem. Thank you.

How do I get the the profile output to flush to the output file? I ask this because when I run one of my programs, I get no data rows, just the headers. However another program I have calls the kernel many more times, and periodically the output is flushed. Am I missing something from the exit of the program? I tried exit(0) and cudaThreadExit().