Cant flash my Jetson Orin NX dev kit

I’ve tried a lot of things to flash my Orin NX 16GB dev kit with an NVMe SSD, but can’t get it working.

Earlier I’ve tried sdkmanager from Ubuntu 22.04. That allowed me to install JP6 DP2 once but when I power cycled, it didn’t come alive again. Have been able to reproduce this.

Then I read that others had success when moving to Ubuntu 20.04, so I ran sdkmanager as a docker image using 20.04. Here flashing got stuck when reaching 99% and I had no success getting to a bootable system.

Now I have connected a serial-to-USB adapter, but there is no sign of life when booting after the previous unsuccessful attempt to install.

In an earlier post here lhoang instructed two methods. In both methods, the flash command fails with these famous last words:

[ 10.3922 ] Start flashing
[ 10.3933 ] tegradevflash_v2 --pt flash.xml.bin --create
[ 10.3939 ] Bootloader version 01.00.0000
[ 10.4518 ] Erasing spi: 0 … [Done]
[ 11.4588 ] Writing partition secondary_gpt with gpt_secondary_3_0.bin [ 16896 bytes ]
[ 11.4592 ] […] 100%
[ 11.4624 ] 000000004d4d2c01: E> NV3P_SERVER: Failed to initialize partition table from GPT.
[ 11.6952 ]
[ 11.6952 ]
Error: Return value 1
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing generic.

Similarly on the UART:

I> Populate storage info
I> Erasing device 3: 0
I> QSPI: Erasing entire device
I> Writing device 3: 0.
I> strt_pg_num(1) num_of_pgs(1) read_buf(0x473908000)
I> strt_pg_num(131071) num_of_pgs(1) read_buf(0x473908000)
W> Cannot find any partition table for 00030000
E> NV3P_SERVER: Failed to initialize partition table from GPT.

I’ve now spent quite some time to figure out how I can get this wonderful dev kit working, but I run out of ideas.

I am experiencing similar flashing issues. Did you resolve the issue? If yes, please kindly post solution here, or link to the solution. Thank you.

Hi Harry,

No I don’t have a solution, sitting with a non-functional dev kit and spending my nights in unsuccessful attempts to flash it.

After the above attempts I again ran sdkmanager from Ubuntu 22.04 and it printed that it was able to generate a new GPT, but during the process I get a lot of flashing errors and when the dev kit finally reboots, the last famous words on the UART are now:

[ 311.232028] kvm: exiting hardware virtualization
[ 311.420319] tegra194-pcie 140a0000.pcie: Link didn’t transition to L2 state
[ 311.451211] arm-smmu 12000000.iommu: disabling translation
[ 311.451302] arm-smmu 8000000.iommu: disabling translation
[ 311.451384] reboot: Restarting system
����Shutdown state requested 1
Rebooting system …

Even after a restart there is no sign of life so my suspicion is that the boot process fails. Isn’t the QSPI a new element here that Nvidia hasn’t used earlier? I read that the boot loader doesn’t generate log output by default but I have no idea how I can enable it during the install process, before first boot.

The Xavier dev kits have been much more stable, just saying.

Can you please dump the full log?
I just don’t know what situation it is now.

Sure. Attached you can find the logs from sdkmanager running on Ubuntu 22.04 and the UART output while flashing.

In the end it says rebooting but nothing happens after that. Even a cold restart doesn’t provoke any signs of life other than that the Jetson is getting moderately warm. No UART output or boot logo. The APX device is visible on USB.

SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-02-07_08-37-16.zip (207.3 KB)
SDKM_UART_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-02-07_08-37-16.txt (68.5 KB)

Are you able to flash your board with jetpack5 instead of jetpack6 first?

That is unfortunately a bit more involved since JP5 requires Ubuntu 20.04 that I don’t have at hand.

I tried the approach to pack sdkmanager in a Ubuntu 20.04 docker container and started the flashing process. It stops at 99% and never finishes. These are the remaining processes:

UID PID PPID C STIME TTY TIME CMD
nvidia 1 0 0 19:38 pts/1 00:00:25 sdkmanager --cli --action install --login-type devzone --product Jetson --target JETSON_ORIN_NX_TARGETS --target-os Linux --version 5
nvidia 22 1 0 19:38 ? 00:00:00 /opt/nvidia/sdkmanager/sdkmanager /opt/nvidia/sdkmanager/resources/app/output/dist/service/spawn-worker.js
nvidia 23 1 0 19:38 pts/1 00:00:18 /opt/nvidia/sdkmanager/sdkmanager /opt/nvidia/sdkmanager/resources/app/output/dist/service/downloadService.bundle.js
nvidia 34 1 0 19:38 pts/2 00:00:00 bash --rcfile /home/nvidia/.nvsdkm/.sdkm.bashrc --noprofile
nvidia 3026 34 0 19:45 pts/2 00:00:00 /opt/nvidia/sdkmanager/resources/app/output/installUtils/adapter -a=install -c=eyJjb21wSnNvbk9iamVjdCI6eyJuYW1lIjoiRmxhc2ggSmV0c29uIE
nvidia 3032 3026 0 19:45 pts/2 00:00:00 /bin/bash -c /tmp/tmp_NV_L4T_FLASH_JETSON_LINUX_COMP…sh | tee -a /home/nvidia/.nvsdkm/logs/JetPack_5.1.2_Linux/NV_L4T_FLASH_JETSON_L
nvidia 3034 3032 0 19:45 pts/2 00:00:00 tee -a /home/nvidia/.nvsdkm/logs/JetPack_5.1.2_Linux/NV_L4T_FLASH_JETSON_LINUX_COMP.log
root 3043 1 0 19:45 pts/2 00:00:00 [nvsdkmanager_fl]
root 3224 1 0 19:45 pts/2 00:00:00 [tegrarcm_v2]
_rpc 3316 1 0 19:45 ? 00:00:00 rpcbind
nvidia 3334 0 0 20:14 pts/6 00:00:00 bash
nvidia 3542 3334 0 20:29 pts/6 00:00:00 ps -Af

WIth some effort I have collected the log files from within the container and also attach the uart output while flashing.

uart_JetPack_5.1.2_for_Jetson_Orin_2024-02-08.txt (5.1 KB)
log_JetPack_5.1.2_for_Jetson_Orin_2024-02-08.txt (41.8 KB) Sorry, that is in fact a zip file.

After a restart the dev kit still appears to be dead.

Are you able to flash the Orin dev kit with JP5 using sdkmanager in a docker container on Ubuntu 22.04?

I just found that Flashing Orin Nano Dev Kit NVMe hangs at 99% seems to be another report of the hang I observe with sdkmanager in docker. Unfortunately closed without solution.

Just for the record: Following both “solutions” from Unable to Flash R36 on Orin Nano 8GB Dev Kit Using External Storage results in the same “NV3P_SERVER: Failed to initialize partition table from GPT” error.

first_method_log.txt (79.0 KB)
first_method_uart.txt (17.7 KB)
second_method_uart.txt (22.3 KB)
second_method_log.txt (76.3 KB)

I have spent just too many hours to get this thing running. I’m stuck and would so much only like to get started with Orin and the wonderful world of LLMs. Instead I’m forced to dig deep into QSPI, GPT, ratchets and why value 0x31 is out of range.

Guys, it is working now. I have managed to get hold of an older laptop with an Intel CPU and did a fresh Ubuntu 20.04 install, then using sdkmanager. I’ve first been flashing JP5, then JP6 as Wayne asked for.

The earlier unsuccessful attempts have been with an AMD R5 5600 CPU and Ubuntu 22.04. No idea why that fails while Intel CPU (8th gen) and Ubuntu 20.04 works.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.