Orin NX flashing failed on Xavier DevKit

I’m trying to flash a new Orin on the Xavier DevKit Carrier board. I’ve installed a NVME ssd in the dev kit. I’m flashing using instructions from this post on a laptop running Ubuntu 18.04:

However the flash fails at this line. It seems like the NX just powers off, the power light is not on and I don’t see any data coming from the UART log after this either. I have tried a couple times and it consistently fails at the same spot.

*                                     *
*  Step 3: Start the flashing process *
*                                     *
Waiting for target to boot-up...
Waiting for device to expose ssh ......RTNETLINK answers: File exists
RTNETLINK answers: File exists
...RTNETLINK answers: File exists
RTNETLINK answers: File exists
Run command: if [ -f /qspi/l4t_flash_from_kernel.sh ]; then USER=root /qspi/l4t_flash_from_kernel.sh --no-reboot --qspi-only ; fi on root@fe80::1%enp0s20f0u8u1
blockdev: cannot open /dev/sdb: No medium found
[ 0]: l4t_flash_from_kernel: Starting to create gpt for emmc
Active index file is /mnt/nvidia_dir/nvidia/Linux_for_Tegra/tools/kernel_flash/images/internal/flash.idx
Number of lines is 75
SSH ready
blockdev: cannot open /dev/mmcblk0boot0: No such file or directory
Flash index file is /qspi/internal/flash.idx
Number of lines is 75
[ 0]: l4t_flash_from_kernel: Starting to flash to qspi
Erasing 64 Kibyte @ 0 --  0 % complete writing item=59, 6:0:primary_gpt, 512, 19968, gpt_primary_6_0.bin, 16896, fixed-<reserved>-0, aaed63fa463a7e87fee3b32422c275257bebe3d0
Error: Error opening /dev/sda: No medium found
Erasing 64 Kibyte @ 1a70000 -- 41 % complete 

uart_log.txt (2.1 KB)
flash_log.txt (225.6 KB)

Are you using Orin NX or AGX Orin?
Which JetPack SW?

Orin NX. I’ve tried with Jetpack 5.1.3 from the SDK manager but this attempt was just using the Jetson_Linux_R35.2.1_aarch64.tbz2 file which I’m not sure is associated with a jetpack version.


Apparently you messed up with the usage of quotation marks, so the wrong storage device was used.
It should have been

-p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"

, whereas you used

-p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”

in your command.

SDK Manager does not support the combination of Orin NX/Nano + Xavier NX DevKit.
Please test on 5.1.3/35.5 by flashing with commands.

The quotation marks are just an artifact from me pasting the logs into gedit prior to uploading. I didn’t use smart quotes on the cmd line.

I just noticed you did not give the right UART log.
Please check it again.

My mistake. Correct log attached.
xavier_carrier_board_uart_log.txt (94.1 KB)

I still think it’s about the cable.
Hub can be unstable and please avoid using it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.