Cant install h5py on a nano jetson

when i try pip3 install h5py on the ubuntu 18.04 from nvidia for the nano jetson i get this error

ERROR: Command errored out with exit status 1: /home/mimus/virtualenv/venv/bin/python3 /home/mimus/virtualenv/venv/lib/python3.6/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-sr8cr1rz/normal --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'numpy==1.14.5; python_version == "3.7"' 'numpy==1.17.5; python_version == "3.8"' pkgconfig 'Cython>=0.29.14; python_version >= "3.8"' 'numpy==1.12; python_version == "3.6"' 'numpy==1.19.3; python_version >= "3.9"' 'Cython>=0.29; python_version < "3.8"' Check the logs for full command output.

i have already installed cython numpy and six but im having the same problem, hope you can help me

Hi, what version of jetpack are you using?

hello! i am using the 4.4.1 version, i “solved” it by non installing virtualenv, i also had some problems installing scikit-learn and skimage but when i do it right in the ubuntu’s python user i have no more this problems, as far as i have red i thin it has to do something whit the numpy and pip that the virtual env installs but im not to much sure about this

Hi, I haven’t been able to install h5py even on a fresh installation of Jetpack 4.4.1 … No virtualenvs, no pipenvs, nothing. Just baremetal installation and it fails… You must have done something else to make it work. Please make an effort to recall? :)

Hi, this issue has been solved in another thread. Just in case, the problem was the latest version of h5py requiring some specific version of numpy that in turn had a dependency to some xlocale.h file that has been deprectated and is not available anymore. Pinning h5py to a specific version (2.10.0 if I recall correctly, you can check in a similar thread here) did the trick.