Can't open /dev/ttyACM1

Please provide the following info (tick the boxes after creating this topic):
Software Version
[√] DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[√] Linux

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
[√] other (940-63710-0010-200)

SDK Manager Version
[√] other

Host Machine Version
[√] native Ubuntu Linux 20.04 Host installed with SDK Manager
[√] native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

I had a AGX Orin form our customer , i tried to flash AGX Orin form SDK Manager and Docker container ,but it was fail ,and i used the minicom to connect /dev/ttyACM1 , minicom no respond (type any key no respond) ,i change the TYPE C cable and host machine ,but it still fail ,how can I solve this problem?

driveinstaller.log (36.4 KB)
log_c6e8b013f868f7602e4eb8cdb9c8282a.txt (261 Bytes)

Hi @tueng
Have you ever successfully accessed Aurix via ttyACM1 on any other devkit? Have you referred to Software Setup on the Linux Host?
Please try “Use a USB 2.0 port on the host PC used for flashing” mentioned in the release notes.
Also, after minicom connects to /dev/ttyACM1, please try switching off/on the power on the rear panel of the devkit and see if any messages show.

Yes i had two devkit form customer ,one could not be connected via minicom ,the other one minicom connected successfully but couldn’t enter recovery mode
This is the ohter one devkit in our office

What did you see for the failure of docker flashing? any log?

According to this image and the logs you provided offline, it seems the application was waiting for you to input the password. Please delete ~/.nvsdm directory, try flashing with sdkmanager again and share us ~/.nvsdkm directory.

log_c6e8b013f868f7602e4eb8cdb9c8282a.txt (261 Bytes)
The attach file is the docker flash log ,the next step should be connect /dev/ttyACM1 successfully ,but connect fail ,so the screen hang on the below picture

Before flashing DRIVE OS 6.0.5, did the pre-flashed DRIVE OS work well?
If you can access NVIDIA Orin X1 via serial port or ssh, please follow Flashing AURIX from NVIDIA Orin and try if reflashing the aurix firmware helps with this issue.

HI Vick
My host machine olny install SDKMnanger and docker ,how can i get the “”

The script is on the target side so you need to run it via serial console or ssh.

Hi Vick
Thanks ,but i can’t connect to this devkit via minicom ,so i need to open the devkit case and short pin 1 and pin 2 on Aurix jump , flash Aurix by memtool , is it right?

Dear @tueng,

If /dev/ttyACM1 has no prompt, it can be either due to minicom settings(Check HW flowcontrol set to yes with CTRL + A + O on minicom console). Please share serial port setting details on aurix console. If it does not work, could you check flashing aurix FW(

Please check connecting to Tegra A using /dev/ttyACM0

HI @SivaRamaKrishnaNV
This is my minicom serial port setting

Please check connecting to Tegra A using /dev/ttyACM0

dev/ttyACM0 No shell prompt

Dear @tueng,
Can you make Hardware Flow control as Yes (Press “f”) and save settings. Let us know if it helps?

Can you access to Tegra A using minicom via /dev/ttyACM0?

HI @SivaRamaKrishnaNV
I set Hardware Flow control as “Yes” and still no shell prompt


Can you access to Tegra A using minicom via /dev/ttyACM0 ?
No , the test result is the same with /dev/ttyACM1

Dear @tueng,
So you don’t have access to tegra or aurix by ssh or serial interface.
Could you share the host and target connection pictures

Hi @SivaRamaKrishnaNV
This is our host machine , i usd the type C to type C cable to access the devkit and i tried to access the devkit by other type C to type A cable , but it still can’t open /dev/ttyACM1

My company is LEADTEK , these are our customer devkit ,and we talk about these issue form Email ,one can’t open /dev/ttyACM1 ,the other one can access the devkit via minicom ,but no extra usb device on lsusb output after type the “tegrarecovery on” and “thgraest x1”


The connection looks all good. The specific unit will be shipped back to us for further investigation.