ttyACM0 not detected on host PC

Hi, I am using AGX Orin Developer Kit.
I want to reset my board, so I tried flash with host pc.
However, my host pc does not detect ttyACM0 on /dev/
When I type ‘lsusb’, I can find “NVIDIA Corp. APX” with my AGX Orin connected. (next to 16 pin USB-C)

(I suppose…) In this regard, flashing my AGX Orin with sdkmanager(host pc) fails.
I also tried without sdkmanager, but same error message occurred.

How can I solve the problem? Or, do you have any idea of failing flashing?

My host PC is Dell Latitude 5330 with Ubuntu 20.04.

Additional Info:
This is error message from sdk manager

Hi, for serial connection, you are supposed to use the micro USB port, not the USB-C, which is for flashing. Did you connect it correctly?

For why the flash process failed, if your AGX Orin enters force recovery mode, you should see

Bus <bbb> Device <ddd>: ID 0955:7023/27723 Nvidia Corp.

with lsusb; otherwise, it means you fail to do it.

FYI, check the document for how to enter force recovery mode:

Sorry for the confusion.
When I type lsusb with AGX Orin connected, I receive “Bus ~~ : NVIDIA Copr. APX”.
But same result with sdkmanager.

Do I have to connect both USB-C to USB-A and micro USB to USB-A ?

Serial connection and flashing are two different things. You do not necessarily need to setup UART when flashing, as the flashing log is already shown on your host PC.

For serial connection, you need to connect your device to your host PC via the micro USB port, then run ls /dev/tty* to see if it’s correctly detected.
For flashing, connection is done via the USB-C port, and the device needs to enter force recovery mode correctly. Can you check when you run lsusb, do you get the same device number as shown in my previous reply?

Yes, I receive the same device number as you mentioned.
Please check the attached image below:
Screenshot from 2023-04-21 12-07-11

Hi, can you attach the flash log as a text file here?
Also, want to make sure that do you use a VM or a real Ubuntu system? If you are using a VM, please switch to a real Ubuntu host PC.

I am using real ubuntu system, not VM.
Here is terminal flash log:
Flashlog.txt (4.9 KB)

Looks like there’s some problem regarding USB connection.
Can you try to use another USB cable, or plug your device with a different USB port?
It may be also related to why you get stuck in APX mode.

HI @user51977

Besides changing usb cable, please also try to enable debug message on your host side and flash again.

Share us the dmesg on your host side after you reproduce this issue.

echo 8 > /proc/sys/kernel/printk
echo ‘module usbcore +p’ > /sys/kernel/debug/dynamic_debug/control
echo ‘module xhci_hcd +p’ > /sys/kernel/debug/dynamic_debug/control

Originally, I used USB-A to USB-C cable that is provided inside Nvidia Jetson AGX Orin Developer Kit.

I changed into another USB-A to USB-C that is provided in Nvidia Jetson AGX Orin Developer Kit, but it also makes the same result.
Also I changed totally different USB-A to USB-C cable but the result doesn’t change.

I also changed usb port. Also same result.

I tried to do what @WayneWWW said, but operation not permitted error occured even in the root.

I am going to try with another host PC …

Either run sudo su to switch to root, or use sudo sh "echo..." to get around the permission issue.

Yes I did su to switch to root and tried those.
First one goes correctly, but second one returns bash: /sys/kernel/debug/dynamic_debug/control: Operation not permitted error.
Also third one

Also want to remind that, the forum has changed the format of my comment.

echo ‘module usbcore +p’ > /sys/kernel/debug/dynamic_debug/control

You cannot directly copy and paste. Need to modify the ’ in command.

If that still not able to work on your side, then please change to another host.

Yes, I didn’t copy and paste. You meant ’ left of Enter key, right?

Also I did flashing with another type of host PC (MSI Vector) but it also returns same error…

Please check my flashing process below:

  1. Turn on the Jetson AGX Orin with Recovery mode (middle button pressed + Power jack connect)
  2. Connect host PC and AGX Orin with USB-A to USB-C cable, and open sdk manager.
  3. Select my AGX Orin (Jetson AGX Orin Developer kit 32GB)
  4. Proceed Steps of SDK Manager
  5. Download components (to Downlaods/nvidia/ folder)

Do I miss something?

Do you follow the correct steps as specified in the Developer Guide to enter force recovery mode?

  1. Ensure that the developer kit is powered off.
  2. Press and hold down the Force Recovery button.
  3. Press, then release the Power button.
  4. Release the Force Recovery button.

Please also enable the micro usb port (on jetson) serial console and see if it dump any log during flash.

Solved this issue with runtime mode (not pre-OEM)

1 Like

I don’t really think this issue is related to what you said. Could you clarify more about what you changed on your side?

I just changed “OEM Configuration” of STEP 03 on SDK Manager from “Pre-Config” into “Runtime” and it worked.
I don’t know this depends but I connected both micro-USB port and USB-C port on AGX Orin to my host PC.