Can't set up CUDA Toolkit / GT1030 / Ubuntu 22.04

I have been messing with this configuration for a while and can’t realize what I’m doing wrong.

-AMD Athlon II X2 215 Processor
-Nvidia Geforce GT1030
-Ubuntu 22.04

I have successfully installed CUDA Toolkit and driver following the CUDA installation guide for Linux.

nvidia-smi command seems OK:

| NVIDIA-SMI 535.54.03 Driver Version: 535.54.03 CUDA Version: 12.2 |
| GPU Name Persistence-M | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap | Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 NVIDIA GeForce GT 1030 On | 00000000:02:00.0 On | N/A |
| 33% 42C P0 N/A / 30W | 355MiB / 2048MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| 0 N/A N/A 1324 G /usr/lib/xorg/Xorg 106MiB |
| 0 N/A N/A 1534 G /usr/bin/gnome-shell 72MiB |
| 0 N/A N/A 3856 G …irefox/2356/usr/lib/firefox/firefox 174MiB |

I also added NVCC to the path and exectuted nvcc --version:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Mon_Apr__3_17:16:06_PDT_2023
Cuda compilation tools, release 12.1, V12.1.105
Build cuda_12.1.r12.1/compiler.32688072_0

I’m able to compile CUDA examples using nvcc. However, I always end up getting an error when executing:

(base) valvarez@ubuntu-vad:~/cuda-samples-master/Samples/0_Introduction/asyncAPI$ ./asyncAPI
[./asyncAPI] - Starting…
CUDA error at …/…/…/Common/helper_cuda.h:801 code=802(cudaErrorSystemNotReady) “cudaGetDeviceCount(&device_count)”

Other relevant information:

(base) valvarez@ubuntu-vad:~/cuda-samples-master/Samples/0_Introduction/asyncAPI$ sudo lshw -c video

product: GP108 [GeForce GT 1030]

configuration: driver=nvidia latency=0

(I don´t think there is an issue with nouveau drivers)

(base) valvarez@ubuntu-vad:~/cuda-samples-master/Samples/0_Introduction/asyncAPI$ sudo systemctl status nvidia-fabricmanager
× nvidia-fabricmanager.service - NVIDIA fabric manager service
Loaded: loaded (/lib/systemd/system/nvidia-fabricmanager.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2023-06-28 10:19:20 CEST; 3h 19min ago
CPU: 7ms

jun 28 10:19:20 ubuntu-vad systemd[1]: Starting NVIDIA fabric manager service…
jun 28 10:19:20 ubuntu-vad nv-fabricmanager[36526]: request to query NVSwitch device information from NVSwitch driver failed with error:WARNING Nothi>
jun 28 10:19:20 ubuntu-vad systemd[1]: nvidia-fabricmanager.service: Control process exited, code=exited, status=1/FAILURE
jun 28 10:19:20 ubuntu-vad systemd[1]: nvidia-fabricmanager.service: Failed with result ‘exit-code’.
jun 28 10:19:20 ubuntu-vad systemd[1]: Failed to start NVIDIA fabric manager service.

nvidia-bug-report.log (2.1 MB)

Does anybody know what could be wrong with the installation? I can make it work using the same GPU in Windows 10 on an Intel i7-3770 CPU, So I’m suspecting the problem might be the OS or (rarely) the CPU. On Ubuntu, I have also tried other driver/toolkit configurations but the problem persist.

Thank you in advance!

Problem solved changing to Intel Quad Q8300 CPU (and motherboard)