Can't use more than six cameras with Virtual Channel ID

Hi all,
In RidgeRun we have made progress implementing virtual channel ID.
Our hardware setup includes a D3 2xOCto board with IMX390 cameras, this camera interface board is able to manage 16x cameras. See more information about this interface board: https://www.d3engineering.com/about/news/designcore-interface-card-has-16-camera-sensor-channels-to-speed-ai-system-development-with-nvidia-jetson-agx-xavier-developer-kit/

We have enabled 2 cameras per deserializer (8 cameras in total) but we can only get video streaming from first 6 cameras, the last 2 cameras aren’t working because the documentation doesn’t provide which value should be used at position parameter at device tree when using an eight-cameras system.

We used the values provided in this link: https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fcamera_sensor_prog.html%23wwpID0E0QAB0HA

Camera0 - bottomleft
Camera1 - bottomright
Camera2 - centerleft
Camera3 - centerright
Camera4 - topleft
Camera5 - topright
Camera6 - ???
Camera7 - ???

I have tested with top, rear and others but cameras 6 and 7 don’t work.

The position property seems to be the issue, I can set the following position values:
Camera0 - bottomleft
Camera1 - bottomright
Camera2 - top ---------------> Not valid for 6 camera config.
Camera3 - bottom -------------> Not valid for 6 camera config.
Camera4 - topleft
Camera5 - topright
Camera6 - centerleft
Camera7 - centerright

Moving the position values I can get video from camera6 and camera7, but not from 2,3.

Which values should be use to enable video output from 8 cameras at the same time using NVarguscamerasrc?
Is there a specific setup in device-tree to enable video output using more that 6 cameras with NVarguscamerasrc?

Regards,
Greivin F.

Have a try below lib.

https://devtalk.nvidia.com/default/topic/1056808/jetson-agx-xavier/grab-image-by-libargus-but-image-is-replicated/post/5358762/#5358762

Hi ShaneCCC,

That library fixed the issue.
Thanks!

Greivin F.