Cant write image on card

I tried to write image on sd, but after all i have 12 discs. I tried etcher and win32 imager, neither. Always 12 discs. Problem to in pc, i user laptop, the same, and i successfully wrote img on raspberry

hello reacount1393,

did you mean you cannot create the image to microSD card for Nano platform?
could you please refer to Write Image to the microSD Card, for the steps to prepare the SD card image.
thanks

i tried. and that makes me confused. i am making everything by instruction, but…

hello reacount1393,

couple of question as below,

  1. according to your screen recording, did Etcher tool actually complete writing and validation the image of your SD-card?
  2. may I also know what’s the physical size of your SD-card? thanks

So, i tried couple of sd cards, 32,32 ang 16 gb. at recording i used 32gb. So, i also used new kingston 16 gb sd, bought and used. The same

Yes. As always

hello reacount1393,

I don’t understand, why the issue here mention “Cant write image on card” since Etcher tool complete writing and validation the image of your SD-card.

did you mean you cannot boot-up into ubuntu with the sdcard?
please check Jetson Nano – Serial Console, and gather messages for checking.
thanks

as you saw, after writing img, i cant see what on sd. every disk win tries to format. that is the problem, and that is why jetson cant be booted

hello reacount1393,

it always erase the card and writing several partitions for Nano.
for an alternative approach, you should execute with create-jetson-nano-sd-card-image.sh script file to generate an image blob, it will shown message to indicates the details of partition creations.

may I know what’s the image you’re using,
also, please gather the logs about your board cannot boot-up.
thanks

so, it is okay that it creates 12 discs?

also, is it possible to make first boot from ssd?

hello Rexsell,

assume you’re working with Nano without eMMC, it’s boot from sd-card.
please check below flash configuration for the default partitions of Nano platform.
$OUT/Linux_for_Tegra/bootloader/t210ref/cfg/flash_l4t_t210_spi_sd_p3448.xml

may I know what’s your mean about creating 12 discs?
thanks

I have same issue

I have same issue

hi all,

please check the tutorial page, Getting Started With Jetson Nano Developer Kit.
and also the Development Guide, Flashing and Booting the Target Device for more details.

besides,
please share the details steps and the environment setups.
we’ll need enough information to help you moving forward.
thanks

according to my recording, everything was made step-by-step by this instruction, and you saw the result

Just a note which might partially explain some of this.

Many partitions are used, and the SD card as a whole is the disk, while the partitions each have an independent purpose. Those extra partitions are binary and are not something Windows (or any operating system) can mount and use as a disk. The “root filesystem”, or rootfs, is the only mountable partition, but is formatted as ext4…no Windows system understands ext4 and thus won’t see it as usable. You might be able to find software which adds the ability to read this, but normally only a Linux system understands ext4.

Embedded systems do not have a BIOS. Those extra binary partitions make up for this and are used during boot. Once boot is achieved only the rootfs is used. The rootfs is the operating system, the rest are used prior to the operating system loading (once in RAM the job of those other partitions will basically be to overwrite themselves with the running Linux system).

May be. But when i mounting sd in jetson, jetson doesn’t starts, so just green light on him and no image on screen

https://www.dropbox.com/s/b8ks2flnafibc81/Видео%2004.11.2019%2C%2014%2039%2058.mov?dl=0

Sometimes video configuration is an issue, and this makes it appear the system is not booting even when it is. If you can get a serial console log, then this would be useful for video configuration issues:
https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

On the other hand, there is also a strong possibility that the power supply simply is not stable enough right at the moment of power up, and this would cause a true boot failure. Jetsons are rather sensitive to very short power spikes right at the moment of power up (it is a case of power stability needing to be very tight right at the moment boot starts…even supplies capable of high current output would fail if that tiny spike in power is too much). For the purposes of power you could use shorter or heavier wiring for power. USB supplies make modification somewhat difficult, but you could go to the alternate power header (there is a jumper needing change to do this, and because of a reverse protection diode you might need about 0.2 volt higher supply with the non-USB power delivery method).

i tried this method, but nothing. yep, the problem was in power supply, i changed on dc-dc converter, and it seems Jetson working. but no image on screen and nothing at minicom.

If for some reason you are using a serial console, and there is a stray character sent to the Jetson early on in boot, then likely it is stopped waiting in a U-Boot prompt. In particular, minicom was designed to work with old modems which required an “AT” command set to set up…and if your minicom is sending some sort of init command, then this would cause the Nano to halt if that command is at the wrong time. Try gtkterm instead of minicom. If you are on a host PC with gtkterm, and if your serial port is “/dev/ttyUSB0”, then this would be a correct serial console start command:

sudo gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyUSB0

(if your user is a member of the “dialup” group, then probably no “sudo” is needed)

If you have an actual monitor attached, make sure it is HDMI and does not have a VGA adapter.

my pc even doesn’t see a device /dev/ttrUSB0, the file doesn’t exist