Card did not respond to voltage select!

Hello.

I’ve just completed this tutorial :

I’ve flashed the sd card and I tried to boot it. But it won’t work. the error is : “card did not respond to voltage select”: I would like to know if the reason of the error is because I haven’t the antmicro model or it happens for some other different reason. Thanks.

That tutorial is using emmc module board config. But it sounds like you are using sdcard module…

ohhh very thank man. so i found the reason. can i buy the emmc module only without buying a new jetson nano board ? or can i buy an adapter from sd card to emmc ?

If the sku of your carrier board is b01 jeston nano devkit, then the emmc module would be compatible.

However, if that is A02, then you need to buy a new carrier board too.

yes,I have bought the B01 version. can u provide a link where I can buy the emmc module ?

Please refer to

A generic help is not useful at all and usually leaves me unsatisfied. There are a lot of products and I have already tried to look for the emmc module,but without having been able to find it.

There are only 3 products in the jetson nano page.

One 2gb devkit, one 4gb devkit and one thing looks like a module.

Click into the the “buy now” and look the spec shall tell you the answer.

man,that module costs almost like the carrier board. what’s che convenience in doing so ? In addition Im not sure that’s good for me. Where it should be connected ? I don’t see a proper connector on my carrier board. I think that I’m using the connector to power on the power fan.

If you didn’t know the module can be unplug from your devkit, please refer to the guide.

u gave me a very generic link. can u be more specific ? thanks.

Is it really that hard to tell which document you need to check?

Is really that hard to understand how much informations are stored inside each guide ? is really that hard to understand how much can be hard to find the exact information one needs inside one only of those guides ? I’m a psychologist,non a programmer. I “play” with my jetson nano as hobby. Yes,usually I’m able to end complicated projects even if I make a totally different job,but I don’t want to be overloaded with the informations when they are included inside a very technical guides.

Actually, this has nothing to do with programming. What we are talking about is how to remove the module from your carrier board physically. I guess there is no need to be a mechanic to know how to use a screwdriver, right?

Jetson Nano developer kit user guide is just like a manual to teach you what interface is on the devkit. And it will teach you where the module is located.

And just some personal opinion, there is no need to use your job as an excuse to say you cannot learn something. Based on what you’ve shared or asked on forum, I even think you are some kind of experts.

Moreover, what I tend to do here is give users some tips so that they can find out the answer by themselves. So please forgive me usually not willing to tell the answer directly. Learning where a module is located on the carrier board should not really overload you.

I know. I meant programming in a very large terms. In my opinion even changing some part of an operating system or adding or removing an interface can be called “programming”. You take for granted so much things. I don’t even know if I should remove “the module on my carrier board physically”. which module ? I don’t have any module attached. As I told you,I have only the power fan and the sd card slot. You gave me a very generic link,that points to more than one guide. Now you have straightened your aim,talking about the “jetson nano developer kit user guide”,but before you gave me more than one guide. No man,I don’t want to use my job as excuse,I’m not against learning things. But I have my personal approach to do that. Usually I look for detailed informations,not generic. To say “read the manual” is not useful at all for people who don’t have an high level of experience. It is also offensive. I’m sure that if we overturn our roles and I was me to say “read the manual”,you will understand. The first answer would be “which manual / which part of the manual”,since there are a lot of manuals,with a lot of informations inside. It was even premature to talk about a manual,since it wasn’t clear how to frame the problem. A lot of these informations are not useful and they take a lot of time to be excluded. It takes a lot of time only to understand what is relevant and what not. You are trivializing the question, but doing so you lose the prospective of how much complex is the subject that we are talking about and you become unable to put yourself in the “shoes” of someone who does not have strong foundations.

Ok, sorry about that. let me start from the beginner level.

There is actually a module and a carrier board to form as what we call “devkit”. We also sell the emmc module as separate product so that some customers are able to make their own custom board.

Our previous discussion is if you want to re-use the carrier board, you need to remove the sdcard module from your carrier board and then plug the new emmc module.

The document has 26 pages and there will have a overall picture to tell you where the module is located. The module is just located under the black heatsink of your jetson devkit.

And we are talking about jetson nano, so it should be straightforward to know what you should read jetson nano devkit user guide.

This is how a module looks like. It is has two kinds for jetson nano, one has sdcard slot on it and can take an sdcard image. And another one with only emmc but no sdcard slot. For that kind of module, you need to use sdkmanager or flash.sh to flash the OS into it.

And this picture is from the document. This is the top view of your devkit carrier board. The J2 SODIMM Connector is where the module is located.

now its more clear. thanks. To buy my jetson nano I spent 140 euros. The emmc module costs 110 euros. Don’t u think that for me its a better choice if I buy a new jetson nano with the emmc included ? how much it costs ? is this product already in the market ? I’m not even sure that it will help me to install succesfully Android. Where did u read that the jetson nano by antmicro used for making the android tutorial is equipped with the emmc module ?

After another frankenstein operation,where I have mixed together two kernel configurations. This :

git clone https://github.com/antmicro/kvm-aosp-linux.git

and this :

git clone https://github.com/OE4T/linux-tegra-4.9.git

I’ve got this error :

[ 1.074939] EXT4-fs (vda): couldn't mount RDWR because of unsupported optional features (4000)

[ 1.078049] init: [libfs_mgr]__mount(source=/dev/block/vda,target=/system,type=ext4)=-1: Invalid argument

[ 1.081515] init: Failed to mount /system: Invalid argument

[ 1.084120] init: Failed to mount required partitions early ...

[ 1.096129] init: #00 pc 00000000000e90a0 /init

[ 1.097856] init: #01 pc 000000000006c4d8 /init

[ 1.099631] init: #02 pc 000000000006e930 /init

is this error caused by the fact that the tutorial has been written having in mind the Jetson nano by antmicro,that’s equipped with the EMMC instead of the sd card ?

It was necessary to mix both the two repos because after the first one I get the error message

“initialization of device arm_gic failed. Kvm with user space irq chip only works when the host kernel supports kvm_cap_arm_user_irq”

The second one repo fixes this error, but can’t do anything against the fact that my board is equipped with the sd card and not with the emmc slot. is this correct ?

As far as I know, there is no devkit with emmc module included. I mean, If you buy a “devkit” from the market, it will be definitely a sdcard based module.

I’m not even sure that it will help me to install succesfully Android. Where did u read that the jetson nano by antmicro used for making the android tutorial is equipped with the emmc module ?

And sorry that I don’t know whether it would definitely work or not. That antmicro project is provided by other experts here. NVIDIA does not provide any Android project for jetson nano.

Maybe you can contact with that guy from github and ask if he can provide a method to let you work with sdcard module.
I guess there should be software method from him because the boot process between emmc and sdcard based module are just some device tree files. However, because I don’t know if there is any customization on his side, I cannot give a promise either.